Bug? X-rayed + backfaces shown in all (viewport) render modes

rhinowip

#1

Suddenly all my Viewport display modes (rhino render) only produces x-rayed + backfaces. What can have caused that? _Render works OK though. Rhino 5

It seems be haunting only a specific file. Some top secret “healing” command to try?


Edit:
See post below. It seems like SetPt doesn’t play well with Gh in Rhino5 nor in WIP.

// Rolf


(Rodrigo Bárcena) #2

Any bad objects around?
Did you try RefreshShade?


#3

Tried RefresShade, yes.
Found one bad object, removed
Re-run RefreshShade, no go. :frowning:


Edit:
OK, I did the dangerous thing - I opened the file in WIP and saved it back to Rhino5 format, and…

Healed. Miracles still happens. :innocent:

// Rolf


#4

But, the happiness didn’t last long, because I now discovered that it is my GrassHopper definition which causes some Rhino objects to go bananas. When I run my Gh definition in Rh5 the aforementioned x-ray problem is back again.

And more. For example, there’s a square surface in the picture below, but (after “healing”) it has lost its visibility after the first run of the Gh definition. It’s not that this object is “hidden” (it must always be available for the user to guide the baking), and unhiding doesn’t bring it back. In short: Something in my Gh def seems to affect the shader since also other objects (mesh objects only it seems) becomes affected (“x-rayed”).

Fig.1. An invisible object is there (see gumball). This is a little surface that is used to “guide” the baking position of the (grey) sphere & cylinder thing (the Gh baking works, but in Rh5 it also distorts the shader of the meshes in the model).

And I can’t switch to WIP with this project as of yet. Now what?


Edit:
I have now tracked the problem down to SetPt (!). Well, so it seems.

When I drag the “guide surface” around, it all seems to work (at least the guide surface stays visible), but if I try to move the center of that surface using SetPt (see Gif) then suddenly the surface disappears (this surface is referenced from the Gh Def in a surface component, guiding the baking of the ball & shaft).

Fig.2. On SetPt, suddenly the moved surface disappears :

Same problem in WIP 6.

// Rolf


#5

To me this seems like a serious bug. Hopefully someone registers it in the bug tracker (WIP suffers from the same problem).

// Rolf


(Wim Dekeyser) #6

without a concise description and the necessary files to reproduce the issue?


(discobot) #7

Hi! To find out what I can do, say @discobot display help.


#8

See GIF.

And if no one else can reproduce SetPt + bake, well then there’s no bug to register.

// Rolf


#9

(I would of course email the files if asked to send them somewhere).


#10

Trying this on fresh files on both Rhino5 and WIP gives the same result - object disappears.

  1. Add a surface (planar or sphere).
  2. Run SetPt (x,y,z) to World 0.
  3. Bug: The surface will now be gone (invisible, can’t make visible again).

// Rolf


(Rodrigo Bárcena) #11

Rolf, I’m not sure if this is a bug… you are effectively collapsing the whole surface, not just moving the center point.


#12

So, if simply picking an object, its centroid that is, it’s not a valid “object location” that can be moved with SetPt?


Edit: Hm. I would expect this behavior only when the Control Points are visible when selecting them. Selecting the object isn’t exactly the same thing as selecting the control points … But at least now I know what is happening.

// Rolf