Bug: x-coordinate backwards in Back view


#1

In Back view, when a point such as 5,0 or 5,0,0 is typed in appears as -5,0,0 when evaluated. This might be intended, because the view in which you are working (+x) is to the right, but it should not be. Points should always follow the coordinate system, in which one is working, not local to the view you are in.


#2

You can choose whether you want to see locations in world or current CPlane coordinates by clicking in the leftmost pane of the status bar. Analyze Point gives you both on the command line.

–Mitch


#3

That’s not the problem. When a user is in a 2D viewport such as Back, Left or Bottom view and one types in a 3D point such as 5,0,0, the point will actually be placed at -5,0,0. This occurs because the default CPlane for these 3 views follows the same convention as Front, Right and Top where the viewport is (+) up and to the right. But when viewing the 3D model space through the eyes of a Back, Left or Front view the global coordinate system is (+) up and to the left. It is only the local default CPlane that remains (+) up and to the right. Try it and you’ll see. As an example: View > SetView > Back

In my opinion this is a legacy 2D way of thinking (probably from older Autocad programmers) and is wrong for 3D modelers who think in 3D not psuedo 2D where the coordinate system you are working in is (+) up and to the right as seen through a 2D viewport. 3D modelers, especially experienced 3D modelers, are working and thinking in 3D model space not 2D viewport space.

Maybe McNeel programmers might consider changing their way of think on this issue and think unconditionally 3D not partial 3D.


#4

When you set a view, you are not only setting a camera but also setting a CPlane. Anytime you are modeling, you are always drawing relative to the current active CPlane (unless you override this by using the world ‘w’ modifier in front of your coordinates: wX,Y,Z). Front and Right also behave in the same manner that you are describing for Back and Bottom, positive X is always to the right, positive Y is up, and positive Z is coming out at you.

If you want the behavior you are describing, instead of setting the view, try set the camera to CPlane Back, Bottom, Left, etc. That way you are still using the world CPlane (which it seems like you want), but are looking at it with a different camera.

Sam


#5

Just type "w in front of your coordinates - i.e. w5,0,0
–Mitch