BUG with clipping plane

Check the end of the video after the 3:20 minute. The “No lighting” lighting method of the viewport mode seems to generate some bad visual issue with the clipping plane section colour getting black upon any movement of the camera in the perspective view. This should not happen. Most of the other options also result into some slight darkening of the section colour.
The only solution I found was to switch the lighting method to “Ambient occlusion”, though I don’t know it that will do some hit on the performance or not.