BUG:Slow OSnap

Attached file is a large mesh with a single tree block on it. OSnap to the curves on this block are abnormally slow. Hiding this mesh fixes the problem. This occurs even when Vertex snap is off. The block is nonuniformly scaled but the same occurs when the block is exploded. Does not reproduce in RH5Slow Osnap6.3dm (7.1 MB)

Hi Alexander - I can’t get at this file - can you please upload to rhino3d.com/upload ? Thanks.
My guess of the moment is that this file is from Sketchup and has a massively nested block thing in it.


I believe you should have received it via email? Let me know if you did not.

Hi Alexander - nothing so far, that I can see - did you send it to me directly or tech@mcneel.com?


Directly. I think a problem on my end causing uploads to hang. I will try
once more tomorrow.

Hi Alexander - my guess is that you have SnaptoMeshes enabled and this is bogging things down with that mesh present. Try disabling SnapToMeshes and see if that clears it up.



New WIP command? It was already disabled for me.

Darn - if I enable that setting it does bog down on End osnap to the tree lines in your model, otherwise it is normal as far as I can see… Not sure what could be wrong if that is not it.


Not sure what else I have that’s special. I haven’t done a clean install of the WIP since I downloaded it and would rather not… Fwiw, it reproduces on my home machine.