Bug: Rhino options for view settings not being retained


#1

I can’t get Rhino 5 to retain view settings for Rendered display mode: backface settings.
steps to recreate:
I pull the dropdown to ‘Single color for all backfaces’, choose a color, hit ok.
close Rhino.
reopen Rhino, this setting defaults to “Use front face settings”

i’m on sr6, build 10/28.

confirmed on several other machines.

thanks


(Brian James) #2

Hi Robert,

Can you try right clicking the Rhino application icon and choosing ‘run as admin’? You should only have to do this once if it works. This sounds like a rights issue to me.


#3

Brian,
I tried this. Didn’t work. Other options settings changes I make are being retained with no issues at all.


(Brian James) #4

Hi Robert,

Thanks for sticking with me on this one. I have reproduced the issue as well in the latest build and it appears to be a bug in the default Rendered mode. I filed this as RH-22344 which we will try and fix ASAP (this report is not public at this time). In the meantime, I found that if you make a copy of the mode, the backface change will stick between sessions. Here’s an ini file to import into Options>Rhino Options>View>Display Modes.
Rendered with backfaces.ini (10.4 KB)


#5

Thanks Brian, I will give this a shot soon. Looking forward to the fix.


(Pascal Golay) #6

Hi Robert- see if making the change from the Display panel sticks better…? (Panels menu > Display)

Any luck?

-Pascal


#7

Brian, I copied my own rendered view setting and that worked fine. Thanks for the suggestion, I wouldn’t have thought of that one anytime soon.


#8

Hi Pascal, no luck. Still no stickiness between sessions by making the settings changes in the display panel.
Brian’s suggestion of copying the setting is a good workaround for me for now.