BUG REPORT: Dimension zero suppresion expands when changing mask to none

My default dimensions setting is to enable mask. But at times I like to turn off select dimensions that are overlapping a model, and when I do this (select the dimensions in question and change the properties>mask drop down from background to none, the dimensions expand to show the zero feet and inches. So for example, a dimension that is showing as 1/2" will expand to show 0’-0 1/2". And this is despite the fact that under the properties length units, the “zero suppression” setting does indicate “suppress zero feet”. The only fix to get it back to show only 1/2" is to change the suppress zero feet to “no zero suppression” and then right away back to suppress zero feet. I’ve been having to do this for months and just haven’t had a change to log it as a bug here…

The ask: It would be nice for the fraction to remain as is when changing masks manually.
PLEASE fix this in the next update.
Thank you.

Hi Peter - I do not see this so far, but I am probably doing it wrong - can you save a couple of these dimensions out to a file and post it here?



AttachedDIMENSION PROBLEM.3dm (214.6 KB)

Hi Peter - thanks - I see a similar thing happening - as the file opens it looks correct:


But if I change the mask settings to ‘Solid Color’ I do get the zeros as you describe.


Changing that color re-suppresses the zeros…


Thanks for the report.


Weird. I just opened the same file again and it’s showing correctly. However, when I changed the right dimension back to background mask and then again to none, the problem returned. Give that a try and see if you have the same issue.