BUG report, curve preview mirror with zoom


(Riccardo Foschi2) #1

Hi all,
I found a strange and annoyng bug on my laptop (on my desktop it is beheving correctly).

The rhino 6 version is updated and it is in english (on my desktop it’s in italian and it works properly, I don’t know if it matters.)

When I draw a curve on the top view, and I zoom it, it mirrors vertically with regards of the first point and the axis x, furthermore, some times after this wrong behavior it freezes my laptop and I have to reboot it.

Ric


#2

Hmm, sounds like a possible display problem… Can you type SystemInfo in Rhino and post the results here?


(Riccardo Foschi2) #3

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)

Intel® HD Graphics 5500 (OpenGL ver:4.4.0 - Build 20.19.15.4549)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build 20.19.15.4549
Driver Date: 11-10-2016
Driver Version: 20.19.15.4549
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


#4

As your video driver is from 2016, the first thing I might try is to update it…


(Riccardo Foschi2) #5

I just did it, and rebooted the Laptop, but it didn’t work.
I think it’s something related to the dynamic redraw of the viewport once zoomed, is there any option somewhere to cotrol it?


(Steve Baer) #6

You may want to try turning GPU Tessellation off in the OpenGL settings page for Rhino. Many of the older Intel GPU drivers have problems with this feature. Having your laptop freeze is a sign that something is not working in the graphics driver.


(Riccardo Foschi2) #7

YES it worked! it was the tessellation option, set on false solved the problem, Thank you very much!

Just to know what was it doing?


(Steve Baer) #8

GPU tessellation moves all of the calculations for drawing curves onto the GPU which can result in large performance improvements. Unfortunately not all graphics drivers work well with this features and the Intel drivers in particular have been know to be problematic.