BUG: Poor Perspective Performance issues with SubD + Clipping Plane

Hello all,

I started witnessing a serious performance issue seems to be caused by smooth display of few subd objects.
I made a video explaining the issue:

I’m running the latest RH 7.7.21131 on a Quadro RTX 4000, I have OpenGL tessellation = on, AA = 4x and display mesh to be Jagged / Fastest.

You can download and play with the file below:

1 Like

Update:
This is seems to happen whenever you have a clipping plane with Subd (smooth mode) in your project file. disabling clipping plane also remove the lag.

This doesn’t really look like a SubD “display” issue… nor do I think it has anything to do with Perspective vs. Orthogonal projections… I can clearly see your perspective view updating, drawing, panning, rotating in real time…so obviously SubD drawing is fine. It’s only when you’re in a "feedback’ operation, do you see this lag…which tells me that something is most likely causing the display to recalculate and update the fragment mesh for every SubD object, on every feedback frame update…which is not good (obviously).

The differences I see in your ortho view are:

  1. You’re not in a shaded display mode
  2. There’s no clipping plane associate with the ortho view

When a clipping plane is active for a specific view, then certain things happen during feedback operations…

  1. Intersection lines are calculated and drawn for all objects that intersect the clipping plane
  2. Solid “fill” geometry is created and drawn for all closed surface objects that intersect the clipping plane.

The lag could possibly be caused by one or both of those things… You can try turning those off to see what happens (they’re both located in the Display Panel Tab near the bottom)… Turning those off will still give you the ability to use the clipping plane, you just won’t get intersections and fills. My guess would be the fills are causing this lag, since those are the most costly…but obviously this shouldn’t lag the way it is, and things have been optimized to prevent this kind of thing, so either something broke, or certain cases have been missed.

I will look at this tonight and tomorrow (thanks for the model and the report)…

I’ll let you know as soon as I find something.

Thanks,
-Jeff

Thank you Jeff,

I agree, it is a combination of two factors. clipping plane + smooth Subd Display, If I turn off the clipping plane, the lag disappear, same thing If I keep the clipping plane on and switch my subd display to polygon the issue goes away as well.

to be fair, i have noticed that the subdivided display actually is causing some additional lag, that very well could add up to some serious lag depending on the use case and equipment.

i have stated some concerns here

Ok thanks…

Did you ever send the file in? If not, you can send it to me and I’ll take it a look at it while I’m looking into the problem in this thread.

-J

Hello Jeff,
for my file, it is up the main post, I shared a google drive link.

Thanks @tay.alrawi, Yes, I have your file… My question was to @encephalon… sorry for the confusion.

BTW: It looks like it’s the Clipping Plane intersections causing the problem… If you uncheck the option for clipping plane “Edges”, things work much better…

…but that’s just a workaround until I can get this fixed.

Thanks,
-Jeff

1 Like

Thank you Jeff.
That was my workaround, also If i need a quick performance boost, I’d just hit “TAB” and the lag disappears.
I made an abstract version of the problem with a clipping plane + 11 Subd Object and you can see the issue here
Test_Subd+CP.3dm (1.9 MB)

RH-64281 is fixed in the latest Rhino 7.8 Service Release Candidate

1 Like

Hello Brian,

I just downloaded 7.8 Service release and I confirm the issue has been resolved, Thank you for the quick and prompt solution.

Thank you

1 Like