BUG maybe? Can't move the holes of this polysurface

I tried to copy a couple of holes of that polysurface via the ! _CopyHole command, but something prevents Rhino from doing so. The ! _MoveHole _Copy=_No command does not work, either.
However, these two commands eventually worked when I used the ! _ExtractSrf command to extract some surface off the polysurface, then I joined them together again. Only then I was able to copy the holes I needed. Looks like some hidden force “locks” the ability to copy or move holes in this polysurface unless it’s being modified.

Can’t move the holes of this polysurface.3dm (137.5 KB)

Hi Bobi- Hm - looks like it does not like the exstrusion… your extract-and-join made it a brep. ConvertExtrusion also allows the command to work. I’ll test other cases, thanks for the report.
Yeah - it does not work on extrusions, which seems like an oversight to me… but I cannot see how we could have got away with it for so long - this may be a regression.


1 Like

Hi Pascal, I just noticed that the “Use extrusions when possible” option located under the “General” section in Rhino options was turned on, despite that I always keep it off. Maybe it was switched on after the last update of Rhino that I downloaded last week. As you mentioned above, it looks like extrusions are behaving differently when it comes to modifications. I turned off the extrusions and the issue is gone.