Bug?:Materials Editor[Solved](rendering preview of materials)

When selecting some items in Material from Import from Material Gallery,
just downloading the material and the preview rendering seems to run maybe too much load on the GPU…
fan is going crazy.

If you have Cycles selected as your current render engine you will see previews rendered with Cycles. You probably should change to Rhino Render if you don’t want to stress your machine.

Hi @nathanletwory
Updating driver to see if that changes things.
Is it possible to save the thumbmail in the material file after it renders? So that it doesn’t render the
next time when the materials are selected?

I doubt a driver update fixes the load.

If a material gets rerendered on selection there is something wrong with the caching system.

I am not sure if the thumbnails are saved with the file or not. Maybe @andy knows.


Is it possible if thumbnail of material preview to be saved on the material file?

Is there way to clean up the caching? Clean install?

Also, just updated to latest below ver of V6, and the rendering of the material preview doesn’t seem to stop(high sampling?)
Not sure how it was before… is the sampling of the preview also defined by the overall sampling setting?

V6 not releasing GPU? (6.0.17248.9001, 2017/09/05)

@Toshiaki_Takano the preview renders render up until 500 samples, this is currently not configurable. Is that something you’d want?

Yes, if there is a way to lower the sampling that’ll help a lot.
On a laptop setting up the material eats up battery as GPU is in use.

Also one question, when rendering in Cycles, and I close the rendering window, does it stop the rendering?
or is the rendering running in the background?
(if it runs in the background I’ll try not to do that…)

The rendering stops.


Entered as RH-41226 for tracking.

1 Like

RH-41226 is fixed in the latest WIP