Bug: Make2D command produces garbage linework when capturing interiors

I’m trying to use the Make2D command to produce line drawings of the interior of my building. It does fine if the objects selected for Made2D are entirely inside the viewport. But if objects extend out of the frame (like walls or ceilings tend to do), the command drops out linework that’s totally broken and unusable. Usually the linework will be all squished into less than an inch square, and there’ll be a bunch of lines kind of in the neighborhood of where they should be, but it’s as though the precision got all wrong and it decided to ignore most of the edges of objects.

Some screenshots to illustrate.
This view:

when I select the things that are visible and run Make2d, becomes:

Often there’ll be lines projecting past the bounding box of the viewport with intense foreshortening. For instance, this view:

produced this set of linework:
Though that’s really just a detail of the linework it produced, those lines continued down and to the left for quite a ways.

Sometimes I’ll be able to get correct linework if I trim all the offending objects until they’re pretty much contained within the viewport, but this requires I make a copy of the file and rip it to shreds every time I need some line drawings. Which takes a lot of time. And it means that realistically I can’t get a lot of the views I’d like to show.

I feel like this started being a problem sometime this year, that it hadn’t always been this buggy. I feel like I used to be able to just hit select-all and Make2D a shot of whatever was inside the current viewport, and it would correctly ignore the things I shouldn’t be seeing.

That’s it for content. As requested in the instructions for reporting bugs, here’s the pasted info from the About Rhino tab:

Software information

Software versions
Rhinoceros version: 5.0.1 (5A858)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.9.5 (Build 13F1077)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: MacBookPro9,1
Processor: Intel Core i7-3615QM CPU @ 2.30GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 512 MB
Memory: 512 MB
Screen size: 1440 x 900
Displays: Color LCD (111dpi 1x)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.29 310.40.55f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Thanks for the report. I believe this was something being worked on by @GregArden but I’m having trouble locating the bug report… do you recall Greg?

Can you also upload a small sample that shows the problem or send it into tech@mcneel.com referencing this forum link? I’m not able to reproduce it here in a quick test.

Here’s a quick model that showed the bug:
model to show make2D bug.3dm (312.5 KB)

I saved the view that I tested and found that it bugged. (It’s the view I last saved the file from, so it should open up directly.) Run the SelVisible command, box-select everything in the window, and run make2D. The options I ran it with were: Show tangent edges, Show viewport rectangle.

On the “make2D” layer you can see the linework it produced for me. It’s very small, and placed right at the origin.

Tried with 2 point perspective - looks much better. :ok_hand:

This is still being a problem. 2 point perspective doesn’t seem to be fixing it for me.