BUG: Inconsistent blend edge

I did some basic modeling today and there was a strange bug that happened when I tried to apply a blend edge on quite simple geometry with a minimum amount of control points. Check the 27:30 mark in the following video to see the bug. I also include the 3dm file below:

RingKK Bobi.3dm (6.0 MB)

Hi Bobi- I am not getting that bad thing to happen so far…


Hi Pascal, I tried to recreate the issue by untrimming the surfaces of the ring from the 3dm file above, and this is what happened:

Trial #1: Rhino crashed before the preview of the blend edge surface.

Trial #2: A different looking bug happened, and upon trying to complete the blend edge operation Rhino crashed again. Just a moment before that I made a screen-shot that I post below. This time around the preview showed multiple parallel edges on one end, as well as some missing portion of the blend surface at the bottom half. Rhino also became very slow upon that moment just before the crash.

Trial #3: I achieved exactly the same weird shape like the one from my video above and this time Rhino didn’t crashed, so I was able to export the messy model along with the original before the blend edge operation:
Random bug.3dm (5.7 MB)

I also recorded a video for the 3rd trial that will be visible on YouTube soon:

That bug is probably related to the order in which I click to add new handles along the edge. Both crashes happened when I added new handles in different order than the one showed in this video.

Thanks, I’ll see if I can make any of that happen.