Bug In SelLast


#1

I was a frequent user of SelLast in R5. It was helpful in determining the output from the last command executed (think curveboolean with keep all). The menu item explains that it is the last created obj (Select Objects -> Last Created Objects).

There are many instances where SelLast performs as SelPrev or SelParent. Steps to reproduce:

Draw planar crv
Select planar crv
_MakePlanar
_SelLast

It selects the planar crv which is the previous selection and the intended srfs parent. This is not limited to _MakePlanar. SelLast witll return the input from other commands as well.


(Pascal Golay) #2

Hi Eric- what is MakePlanar? Sounds like a script with an alias, maybe? Its not a plain Rhino command.

-Pascal


#3

I don’t have a _MakePlanar command… I do have a _PlanarSrf command though.

If I make a rectangle here, select it, start the _PlanarSrf command and let it create a surface, unselect everything and then run _SelLast, the surface selects, not the rectangle… You see something different?


#4

Sorry, I’m tired - _PlanarSrf


#5

I tried it again and it works. However, I tried it again and it didn’t work.

I am very familiar with this command. It always grabbed the output in V5. I could leave the child (input) selected and call SelPrev to group them. Or I could clear my selection and call SelLast to grab something with history and dump it to child layer.

In V6 it frequently grabs the parent or previous (not sure which one) from many different commands.


(Pascal Golay) #6

Also, Eric, the dash version of SelLast (and SelPrev) has an option - I know it’s lame to hide it like that but it might help - the setting there is ‘permanent’ until you change it. You may have set that in V5.

-Pascal


#7

Forgot about dash option, but either way it frequently fails to select last created.


(Pascal Golay) #8

Hi Eric- can you tell if the problem shows up or not depending on pre-select or not for the command before?

-Pascal


#9

image

So it would appear that option isn’t working either. The original selection remains selected.


(Pascal Golay) #10

Hi Eric - can you confirm that in V5 the exact same steps work reliably? So far here this all seems correct in V6.

-Pascal


#11

How does this seem correct in V6? The video clearly shows it failing 4 times. One time it worked but then wasn’t repeatable.

Yes, SelLast always selected the obj or set of objs created by a command in V5. Edits to parent objs did not affect anything.


(Pascal Golay) #12

I don’t say it works for you, only that I cannot make it fail here. Your clip is too fast and blurry to really see what is going on but in any case I believe you , I just can’t yet reproduce it, hence all my questions etc.

-Pascal


#13

Freshly uploaded youtube videos are grainy. It takes them a minute to have the HD version available. You can also slow the playback speed, or I can record it again.


(Pascal Golay) #14

Hi Eric - I don’t see exactly what you see yet but something similar that I expect has the same cause as is underlying your woes - here, if I make a PlanarSrf and deselect and SelLast I get the surface selected and if I deselect again and SelLast, I get the circle selected and not the surface… clearly that is not right.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45972

-Pascal


#15

Thank you, Pascal.

I also need to log another big bug with obj export. Are you familiar with any open tickets concerning meshes and or exports?


(Pascal Golay) #16

Hi Eric - exporting obj is bad on some systems - very, very slow. Is that what you’re running into?

-Pascal


#17

The speed is fine. I go from Rhino => obj => 3DCoat. 3DCoat does really well parsing obj files from V5, but it has yet to open one from V6. I’ve been ctrl-c/ctrl-v the geometry from V6 into V5 to export as obj. I need to dig into it and figure out if it is the mesh generator or the file writer. All I know as of now is that V6 obj files are 1/2 to 1/3 smaller in file sizes compared to V5 with the exact same mesh settings.


(Pascal Golay) #18

Hi Eric- this is drifting off to a new topic altogether but you might want to be sure to UN-check the NGons setting in V6. (in OBJ export I mean)

-Pascal