[BUG] Hatches print with spikes

,

When I print a hatch, the PDF shows spikes at every node. Below is what I have in Rhino, and what I get in a PDF or preview.


The smaller the hatch is on the page, the more pronounced the spikes get.

Here is a video:

Strangely, if I add a random surface to the scene and repeat the print, the spikes are gone:

However, then the hatch also loses its sharp corners (gets an outline, which makes it thicker):


Rhino file and systemInfo attached.
Thank you!
Hatch Print Issue.3dm (2.4 MB)
SystemInfo.txt (5.9 KB)

Hello - this should be fixed in the next service release -
RH-61829 Print: Solid hatch printing messy
You can get this as a release candidate by setting Preferences > General page > Updates > ‘Update frequency’ to ‘Service Release Candidate’.

-Pascal