Bug ? Gumball is sticky when undoing rotation

Hi,

Doing Ctrl Z on this simple rectangle after rotating leaves the gumball rotated.
All axis give the same result, but not scaling or translation.

Let me bring that to the top.
It only happens if AutoCPlane is on.

Thanks @magicteddy for reporting. I logged RH-75832 Gumball does not undo correctly with autocplane

I can’t reproduce RH-75832 anymore in WIP. Fixed ?

@magicteddy I still can reproduce it here.

Ah yes, it’s a bit different now, it works for a single manipulation like rotate-undo or scale-undo but not if several operations are undone in a row.

I’m not seeing that here:

Hmmm…First mystery of the day.
My AutoCPlane does not seem to follow the rectangle like you which makes the undo working.
But if I rotate twice, then a single undo goes back to world XY alignment.

that’s because my rectangle was not on the cplane. Objects that are already on the cplane will not change the cplane.

1 Like

Aaaaah ! Good to know, thanks.

So yeah, bug not solved :sweat_smile:

Now, it’s fixed. Thanks !