BUG: Graphics bug in Arctic viewport mode

On rare occasions, when I switch to the Arctic viewport mode, there are some unwanted “shadows” that seem to be caused by the rendering mesh. The NURBS geometry itself is properly created and joined, everything is at least G1 tangent continuity, yet the bug appears at certain camera angles. However, when I rotate the camera at another angle, those “shadows” disappear, despite the fact that the geometry remains the same. There are no distant object in the scene, happens in many files, including newly created ones consisting a single object.
There is an option called “Camera based clipping bubble” in the properties of the Arctic mode, that I think may be the reason for that visual bug.
Here is a video that shows the bug in action:

You will notice that at the 4th minute of the video I move the bottom slider and the unwanted “shadows” in the viewport disappear. However, at the moment I close the pop-up window, they appear again. There is also some issue with the clipping that may be related to the z-buffer.

Hi Bobi - I guess this is the ambient occlusion ligthing model - I’ll see if I can reproduce it but it would be interesting to know if changing either of these settings makes a difference:

Also I see that overall the scene is proportionally quite large compared to the likely size of the camera frustum in that ‘bad’ view, and in fact most of the scene is behind the camera in that view as well - I wonder if hiding what is farthest behind the camera will sort it out - I suspect it might but I am just making that up…


Hi Pascal, the 3d model shown in the video is a rear bumper of a car which is less than 4,7 meters long, so the entire scene is quite normal. There are no hidden object far far away. Everything is located within 3 meters from the World zero. I use “Large objects - millimeters” preset. “Advanded GPU lighting” is already used, exactly as in your image above.
Note that the bug happens only when I lower the camera at relatively horizontal orientation and look at the geometry from up close. When I raise the camera at a human height and point towards the low rear bumper which is then far from the camera, all the unwanted shadows disappear and the geometry looks normal.

Hi Bobi - I meant the scene maybe proportially large, compared to the camera frustum in that view. If you can turn on the camera (f6) and look at it in another view, that might tell us something.


I got it. :slight_smile: Here is a screen-shot of the same 3d model with the visible camera in the rest viewports.

Hi Bobi - I think in the video, when this sort of stuff appears:

there is also a view of the model that show considerably more in the scene -


it may be a red herring, but it might be a good test to show and hide that object(s) while watching what happens in the view that goes bad.


That was the original model of the same bumper. :slight_smile: I copied the bumper, then moved it 2000 mm backwards and used it as a reference to design an extra piece to it. So, both models should take no more than 3,5 meters long size.

OK - maybe it is not useful but, what I am wondering about is that the extents of the overall scene, compared to the camera, may be part of the equation here. It might make a difference if there is more stuff behind the camera - I was just suggesting checking that because it might help us pin down where it is going wrong. If the problem occurs even with only the one set of parts, then we need to look elsewhere but it seems worth testing.


1 Like