Bug: display modes

In trying to track down the funkiness I have seen with Rhino 6 display modes,. I have gotten Rhino into a state where it will not save a custom display mode at all. If I create a display mode it is gone when I restart Rhino. Rebooting did not fix the problem.

What other information is needed to resolvce?

How can I clear up this problem?

are you file>exiting rhino or are you hitting the red x and just killing it?


Nothing shocking happened other than the rest of the bizarre display behavior.

ok, back up a bit and give some more details on how you got here.

you are on a mac, but what version and service release of rhino?

can you export your custom view mode then close rhino, and then try to reload it?

Just saving one solved this particular problem.

I was creating about 4 new modes. I would quit. Start back and they would all be gone. Saving one of them appears to have dislodged me from the state I was in.

sometime you just need to whack it in the head a bit… :wink:

Now I can work on the problem that I was trying to diagnose when I ran into this one. I was creating a lot of modes.

I have to take it back. The problem is now back and just saving is not getting me out of it like the last time.

I am running Mojave, 10,14.6
Rhino is

Version 6 (6.24.20079.23332, 2020-03-19)

Then I played around some more and it started saving and retrieving the display modes again. again.

Any reason you have not updated to the latest Mac OS? We are seeing that is the fix for a lot of mac rhino weirdness.

It sounds to me like the Rhino PLIST is horked.

Apparently I will no longer be able to use my 32-bit apps if I upgrade.

I’m with JB on this, (mostly cuz he’s smarter than me)

reset your rhino plist-