BUG: Custom lighting slow


#1

Earlier this week or maybe last week’s update is giving me sluggish behavior/low framerate even with just a cube in the scene. I use custom lighting to brighten my shaded view and disabling them fixes the problem.
Shaded.ini (13.3 KB)

Quadro K4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 376.84)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 2-6-2017
Driver Version: 21.21.13.7684
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Pascal Golay) #2

Hi Alexander - and this mode has been OK up to now in V6/WIP, correct? Here is seems fine. BTW, I notice that you have three identical lights in your scheme - I don’t think it is likely that it is the problem but I noticed it - it might be more efficient to just use one, with a bit more brightness.

BTW, I noticed this - https://mcneel.myjetbrains.com/youtrack/issue/RH-38842

-Pascal


#3

Pascal, Yes no problem until now. To the duplicate lights: Ooops. I’ll try making this custom lighting setup again and report back if there’s any issue.