BUG: Custom Display Mode Funkiness

I created a copy of a the Shaded Mode and changed Surface Edge Settings>Thickness to 0.

Initially, the output looked like this (#1)

then it changed to look like this (#2):

I searched through the settings comparing the default Shaded to my Shaded Copy and the only thing I could find different was the Thickness setting.

So created a new copy of Shaded Copy and changed the thickness and it looked like #1—for a while. I did a Make2d and change some views then I noticed that it looked like #2.

So Created a third copy of Shaded and just changed the thickness setting and it looks like #1 (for now). I have gone through all the settings and cannot find any difference among my three copies of Shaded.

I am trying to figure out why I am getting a difference in brightness in the display modes (and why they appear to be spontaneously changing)./

I don’t know if this helps,. but I saw that I can export INI files for the display modes. I did that for the copies that produce two different displays (attached). I ran diff on them but it shows a plethora of differences between the two when I cannot find any difference on the screen.

Shaded copy 2.ini (6.5 KB) Shaded copy 1.ini (6.8 KB)

UPDATE: I have created new display modes based upon SHADED and over time they have all switched to the duller red color with no change in settings on my part.

As described in another topic, I have been having a problem with custom display mode disappearing.

I have been able to reproduce this problem in the midst of this.

  1. Do a clean start of RHino
  2. Open a file
  3. RHino>Preferences>Display
  4. Make a copy of Shaded
  5. In the copy change Object>Surfaces>Naked Edge usage to Use Separate Settings
    Change edge thickness to 2
    Change Edge Color Usage to Use Single Color
  6. Switch to my new display mode and I get this:

  1. Close rhino
  2. Restart rhino
    9 OPen the same file
    Now my custom display mode looks like this with the colors washed out:

It would be interesting to know how to make this change using rhino setting as such a mode might prove useful.

Any ideas on this one? Easily reproducible on my system. I do not know about others.

I’m wondering if your PLIST is messed up.

The only thing I have tried when really strange things happen, is to reset the PLIST.
This will wipe your customization so make sure you have them saved.

I followed those steps. It wiped out my custom displace mode.
I created a new display mode using the same steps as described above based upon shaded.
I then quit rhino.
I restarted rhino.
And my custom display mode has the faded colors just as before.

I would love to know what setting causes this because it could create an interesting display mode.

In any event, reseting the plist had no effect on this issue but it did have an effect.

I think this bug was fixed for V7 just last week: