Bug? Controls always Rendering

i have not found any method to disable the curve control from showing in renderings. the only workaround seems to be to manually hide the cage before rendering.

I don’t see control objects in the rendering when running the Render command but they are shown in Raytraced mode with the default settings. To disable their view in Raytraced mode, run the Options or Preferences command > go to Display Modes > Raytraced > Objects > Control Points > and enable Hide Control Points, Object and Control Polygon.

hey Brian, on this topic, I think there is no way to stop texture mapping widgets showing in raytraced (or other similar realtime renderer) viewport, so maybe they could be added, or included in one of the existing categories

Done… https://mcneel.myjetbrains.com/youtrack/issue/RH-73172

1 Like


must be a bug then, i deactivated everything as you said its still rendering. yes i mean of course in the viewport sorry i left that info out at first. in the external render window it does not show.

Untitled.3dm (3.2 MB)

I hadn’t tried it with the points off for the Control object, that seems to be the difference. If you turn the points on for the control it will hide in Raytraced with those display settings.

I filed https://mcneel.myjetbrains.com/youtrack/issue/RH-73199 for future reference to request a Control visibility setting specifically as well.

1 Like