Bug: Can't change layer's colours from Layer's Palette


#1

This bug is more significant than the one I posted before.

I just noticed that I can’t even change layer’s colours from Layer’s Palette. I’m running latest Wenatchee (2013-11-18) on OSX Mavericks.


#2

I can’t do so either using the new implemented full screen mode and trying to edit the layer color from the side panel. But if i go via the drop down menu “Window -> Show Layers Panel” (or just ctrl + L)
I can change the color again. It is then “updated” in the side panel after hiding and bringing it back again, though you still won’t be able to change it from there. Until now only the drop down menu method works (to me at least).

I hope i could help!

Saludos!


#3

I am NOT using single window mode, and changing layer colors from the layers panel works fine.
You are not supposed to be able to change a layer color from the object properties window (your other thread).

Max.

Edited.


#4

By fullscreen mode i refer to single window modeling activated in general, not specifically the full screen mode in single window modeling, sorry for being unclear.

So to you editing the layers color from the side panel works just fine…?

I completely deleted the latest Rhino Version for Mac and installed it new again, but it made no difference. I am still forced to use the layers window via drop down menu or ctrl+L to change the color.

Josh


#5

I didn’t mentioned that I’ve activated single window modelling


(Marlin Prowell) #6

Yes, I see this problem when the layer panel is in the side bar. As a workaround, use the floating layer panel (Window > Show Layers Panel) or use the pop up layers panel by clicking the current layer name in the tool bar.


#7

Hi,
I am running Wanatchee (2013-12-02) and this problem is still occurring in the single window mode in the pop-up layer palette (the one that comes off the top toolbar).
I can change the color only through the Layers palette that is on the side bar.

Shachar


(Marlin Prowell) #8

Yes, I see this. Automatically hiding the layers popover window prevents color changes from working correctly. The Object Properties popover also has color wells for changing object colors, so I need to remove the auto-hiding feature from both these popover windows. I’ll leave auto-hiding enabled for the Osnaps popover, because it works really well there.