Bug - Cannot print from an unsaved document

I copied an object to a new file, to get some quick dimensions, when I try to print the file; I get a printer error. If I save the file, it will print.

Steps:

  1. Create New file
  2. Paste Object
  3. Create Layout
  4. Dimension part
  5. Print = Error
  6. Save File (any name, any where)
  7. Print = Works as expected.

Printer is an HP Officejet Pro 8740

Thanks,
Don

Save the file!
#FacePalm

I would have, if it was a file I needed to save, but I didn’t need it, so I didn’t save it, until it didn’t print, for some unknown reason.

#BadAdvice

#LoL

What version and service release of Rhino?

Hi Don - is this the case with pdf as well?

-Pascal

@John_Brock
Version: 6.9.18247.3301, 9/4/2018

@pascal
The Rhino PDF printer seems to work in this situation.

I just tried printing an unnamed file to a network Laserjet from 6.9.18253.21101 here in the office and it worked fine.
My 6.9 is a little newer in-house build.
I’m not aware of any specific fixes this week but I can not duplicate the problem.

If all goes as planned, a new 6.9 will go out this evening.
See if it works for you tomorrow and let us know please.

6.9.18253.21101, 9/10/2018

I grabbed the latest one available.

Apparently it is only the HP Officejet Pro 8740 driver that has a problem, the other printers on the network do not generate an error.

It seems to have something to do with the document not having a name in the print manager.

Probably not a high priority item, and probably not even your problem to begin with.

HTH,
Don