Bug: Block outlines hide in Technical, Artistic, and Pen views


#1

I’ve run into this bug a few times, and just again today while using the BoltGen script.

Bug Description: In the views called “Technical”, “Artistic”, and “Pen”, the blocks outlines seem to be ‘hidden’.

In “Pen” and “Artistic”, the block outline is completely invisible. In “Technical” it shows up as ‘hidden line’.

To repeat the bug:

  1. Open the attached 3dm file screw.3dm (1.4 MB)
  2. Switch view mode to ‘Pen’. (you should see the screw)
  3. Select the screw and type ‘Block’, then hit enter.
  4. Confirm the block creation (click OK).
  5. Is the screw still visible in PEN display mode? (it vanishes for me)
  6. Switch the display mode to ‘Technical’, and you can see that all the edges are ‘Hidden’ edges.

This is the first time I’ve been able to reliably reproduce this bug, so please take a good look at it! :wink:

Thanks!


#2

The game continues----

Once you’ve put the screw inside a block (and it is invisible):

  1. Open the block for in-place-editing
  2. Draw a simple cube
  3. Delete the screw geometry
  4. Click ‘OK’ to save the block (now the block has only a cube, no complex screw).
  5. Look, the cube is still invisible!

But if you make a BRAND NEW block with a cube, the new one works fine.

Continueing the above sega, but with the original screw block:

  1. Explode the screw block (now it is visible again).
  2. Explode the surface (81 surfaces).
  3. Select ANY of the surfaces (only one).
  4. BLOCK the selected surface.
  5. Presto: The surface inside the block is invisible.

I’ve even tried putting just the CONE (under the screw head) into a block, and it turns invisible.
Which led me to creating a TCONE in a NEW FILE, and guess what? It’s invisible!!!

It turns out there are a few other basic shapes which also vanish in PEN mode: Just open this magic 3dm file magic_blocks.3dm (939.1 KB) and compare the individually blocked shapes on the RIGHT, with the un-blocked shapes on the LEFT. It seems only the CUBE and CYLINDER shaped objects escape the eraser.

Or is it just me?

Though I have to admit, I kinda like the shaded version without outlines:


(Margaret Becker) #3

Sorry for the delay in responding. This has been posted to the bug list: http://mcneel.myjetbrains.com/youtrack/issue/RH-27585


#4

Thanks @margaret! Perhaps we could even add the ‘No outline’ option in the Pen Display mode? :smile:


#5

I’ve been using this workaround since V5 came out. It may be a known bug, but how long does it take to fix this?

I edited the blocks and added a line in the block. After that you have to move the geometry to have it show up properly. I use nudge twice to do that…

Good luck

Jim
magic_blocks workaround.3dm (939.2 KB)


(Jeff Lasor) #6

All I can say at the moment is that it’s my list still… and right now it’s targeted for 6.x…which means not 6.0. It’s just not getting as high a priority as some users want due to all the other issues ahead of it.

I will try to take a look at it this week to assess the level of difficulty…Technical modes are simply display tricks played on objects’ render meshes… Blocks are special cases because there only ever one set of render meshes for any number of block instances. Which means, hanging any technical trickery off of the object for display purposes probably won’t work very well for blocks. If I were to guess, the problem here isn’t that the outlines are disappearing, but rather, they are getting drawn, just over the top of the ones in the other block…if that makes sense.

Again, I’ll try to get a more accurate feel for what’s happening here and how bad things are.

-J