Bring to Front GH preview geometry?

Hi everyone,

I remember that while using Rhino 5, when I selected any component in GH, the preview of said component would always be on top of Rhino geometry.

Now in Rhino 6 something changed and that is no longer the case.
No matter the Display Mode, if it is wireframe, shaded, etc. GH geometry is always behind, and I cannot see it unless I hide or delete Rhino objects…

Anyway to go back to the previous behaviour?

This is what I mean, it makes it really hard to work this way, I can barely see the selected geometry.

On which release of Rhino 6?
What are your Rhino OpenGL properties?
Are your gpu drivers updated?

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport siz

e: 16384 x 16384
Total Video Memory: 4 GB


Are you telling me this is only happening to me?

… Sorry, I can’t tell.
If I had that problem, I would have probably uninstall (clean) and reinstall both, gpu drivers and rhino…
I hope you’ll receive some help from the developers.