BrepBrep intersection not threadsafe in Rhino 5 64bit?

Hey Anders,

as far as I dicussed the matter with Giulio it probably isn’t the .net. Also on the System I first used the script on the same .net version is installed.
Giulio is kindly taking some time to look into the crash dumps. If he/we find/s a solution or, for that matter, the source of the problem, I will post it here.

It is indeed a longshot, but I did previously experience code/GH definitions that breaks/throws errors due to an out of date .NET framework when issuing code/GH definitions to team members. Hope you guys figure it out :slight_smile:

Just sent an error report as i do get the crash here too. I´ve disabled the GH solver, opened the *.gh file, then enabled the solver. Rhino 6 Wip crashed even when the Python component was not connected. Same happens when i just open the *.gh file with enabled solver.


@clement have you tried deleting the unconected one? Sounds as if you get the crash from the “not parallel” version.

Thanks I see your report @clement

@SmallChief, i do not get that far. Once i try to open it, GH asks me to use the recovery file. If i do it or not do it, it crashes. Lets wait what Giulio finds out from the crash reports.


No, i can confirm that if i disable solver, delete the unconnected one, then enable solver, it crashes.


I generally found everything i’ve tried to do threaded so far causes a crash,.
Either an access violation during the function call, or the function call returns ‘bad data’ (e.g. empty lists)

for example, this works fine in single thread but spuriously fails in multi-thread (note it’s being called about 3000 times):

var offsetEdgeCurves = edgeCurve.Curve.OffsetOnSurface(edgeCurve.MirrorBrep.Faces[0], distance, 1e-3);

note that i’ve guaranteed thoroughly that no other thread is accessing either the edgeCurve or the MirrorBrep

Hi @elliotwoods

I’ve worked with the developer of BrepBrep and we are still reviewing the bug. It’s internally tracked as


Giulio Piacentino
for Robert McNeel & Associates