Box Edit Pivot Location - greys after single axis selection

Here’s one that’s been slowly eating away at my soul for months now.

Select an object - a closed square crv - go to change the Pivot Location in the Box Edit - say, you’d like to set the object’s size and/or location to be taken from Min-X, Min-Y, and Upper Z. But alas, all of those are currently set to the wrong setting. So you go and click the little selection for the X axis at Min, and then before you even get to Y – Greyed out. You can only select one pivot per turn.

I use it a lot, so it’s a big issue for me, so I assume at least a handful of other people out there. Anyone have a solution?


Hi Alan,

Boxedit does lurch from one bug to another, but your issue isn’t one I recall seeing and cannot reproduce in the latest SRC (7.12.21306.15001, 2021-11-02). What version of Rhino are you running?


Same here.


Hi @Alan_Farkas,

After a little more investigation, I believe you may have ‘Pivot Location’ set to ‘Use Gumball’: that permits the behaviour you describe - but the ‘X:’, ‘Y:’ and ‘Z:’ settings are irrelevant if you are using the gumball, so the initial change allowed is moot.

Set ‘Pivot Location’ to ‘Use bounding boxes’ and all should be well.


1 Like

If “Use Gumball” is selected and the Gumball is active I get the behavior Alan describes.

If “Use Gumball” is selected and the Gumball is not active the pivot locations can be selected as usual.

Great job by Jeremy to determine the cause of the problem.

1 Like

If “Use Gumball” is selected and the Gumball is not active then BoxEdit appears to function as if “Use bounding box” was selected. Behavior with a block may be different.

Thank you David. Nice spot from you re. the gumball state too.

This is great news, thank you @jeremy5 Thx for taking time to figure this out.

1 Like