Booleans, no failure message?

There are 2 cubes with a 0.01 gap.
Boolean union will not work.

But also there is no message that tells me it failed:

V5 is more verbose.


@chuck did you see this?

Hi Charles,

If I union these boxes, I get

Command: _BooleanUnion
Boolean union in progress… Press Esc to cancel
Objects do not intersect. Nothing done.

In your screenshot I don’t even see the middle line. I wonder if there is something else going on, unrelated to the boolean operation. Please try with my boxes to make sure it doesn’t have to do with the particular geometry. Also, my tolerance is 0.01, same as the gap. What is yours?


boxes.3dm (55.3 KB)


I tried to create an example, but now it seems all to work ok…

CP_Boxes_V5.3dm (28.3 KB)
Open it in V5.
Copy the 2 objects to the clipboard
Start V6 WIP.
Paste the 2 objects.
Then BooleanUnion.


Same message for me. What tolerance does your v6 document have? My default had 0.001, same as the v5 file. I also tried changing to 0.01.


V5 tolerance = 0.001
V6 tolerance = 0.001

I see now it is not enough to load the file into V5.

Open a V5 and a V6 with both no model loaded.
In V5, make a cube 10x10x10.
Copy that cube by drag + Alt, distance 10 in X.
(Now the cubes touch.)
Move the copied cube X+0.01.
Select both cubes, copy them to clipboard.
Paste them into V6.
Then Boolean union.

Do you now get the effect?


Wow. That’s strange. And once I did that I couldn’t get the message again until I did a boolean that succeeded. Thanks for the report.

Looks like just cut/paste from V6 to V6 is enough the kill the message.


There’s a bounding box test that weeds out objects that can’t possibly hit anything else. If nothing is found, the command exits without a message. I’ll fix that, but I’m much more concerned with the fact that it does not behave consistently.

Fixed. This should no longer happen in the next build. The bounding box checker had a small problem that caused random results. As far as I can tell, the only symptom was that things which did not intersect sometimes did not get the message.