Boolean Union vs. Create Solid when exported to STL for printing in 3D wax


#1

I’m trying to print my project in 3D wax. And the printer reports an error.
I believe (not sure, tho) it’s due objects which are overlapping.
Like, for example, the prongs in the yellowish and fuchsia (the pinkish ones)

Wanted to know which is the correct command to union 2 or more objects, before I export it to STL.
Boolean Union, Create Solid, or may be smth else?

OR may be there is an error, due some “free” space between the objects. Thou I tried not to leave any even the tiniest gaps between objects.

Thanks a lot for advices in advance!


#2

I am not familiar with 3D printing at all, but I could imagine that a 3D printer has problems printing the green bow, where there is, at best, only a single line contact with the base. May be you should trim the whole thing at a fraction above the base. The ‘wirecut’ command seems a good one here, since it trims and closes the gaps at the same time, so you will have all solids again.

Max.


#3

You should use BooleanUnion to try to “fuse” your objects into one closed solid. If they overlap sufficiently, this should work. If not, you may need to go back and see at what joints it is failing, and why.

Here is some info on working with Boolean operations and creating closed solids

HTH, --Mitch


#4

Thanks, @maxz, thanks @Helvetosaur, I will try both options and will report how it goes with my wax 3D model.


#5

Feel free to post the model here if you have problems… --Mitch


#6

Hi Eva, do what Mitch said regarding making sure that your object is one solid. Once Boolean unioned, with the right supports and on the right angle, that piece should print fine.

When it comes time to make a piece solid I either create a new file or copy all the pieces to the side and then union. This means if I have problems I can go back to where I was easily.

One thing to do before you export your mesh to STL is to run the “check” command. This will give you some idea of what if any problems there are with your object.

Good luck.


#7

Practically, in regards to 3D printing, a lot will depend on how you are running the 3D printer. Some of the software that sets up the model to send to the printer (‘slices’ it) is very fussy about overlapping solids - KIssSlicer for example - some is less so.

If you are sending it to a bureau for outputting through a pro system of some sort - which you probably are if you are getting a wax output for metal casting - the file will probably be ‘cleaned’ first by the bureau using high-end pre-processing software like ‘Magics’ which scans through the file for malformed faces, odd normals, overlapping solids and all sorts of other stuff. In which case, it almost (I say ALMOST) doesn’t matter so long as you send an STL which looks the same when you re-open it in Rhino. Either way it is worth talking to the bureau.

Still, it is good practice to send the best file you can. I boolean everything together using a series of boolean union commands, adding single objects one at a time to an increasingly large and complex one. It doesn’t ask too much of Rhino, and when something doesn’t work, you can tell which bit it is. I then run ‘Merge All Faces’ to tidy it up and double check for unjoined edges or weird normals. The STLs coming from that tend to be pretty clean.

PS, I wouldn’t be too worried about the green tube, and the printer should be able to deal with the undercut, either by the way it stacks the layers or by ‘support material’ which is tidied up at the end.

Cheers
Peter


#8

Thanks @sochin, thanks @dromepeter! Will go through all your advices and will keep you posted on my progress.
Thanks a lot again everyone, for such a wonderful support!!!


#9

I have been going forth and back on the model making a Boolean Union.
All solids will fit in one boolean union - Except one (the same multiply pink prong bases) won’t fit:(
I looked in the info link you posted and in the other topics in forum and I do understand there is some overlapping issue. But I can not figure out how to solve it. Even tried to cheat and add some small object which overlaps both and the do boolean union twice, but it did not work either!
Any ideas?

Thanks a lot in advance!Cluster_Earring_UNION.3dm.zip (1.2 MB)

See the PINK & YELLOW prongs - which are problematic
Also attaching the file.

P.S. Just to note - all other objects are doing boolean union just fine. In the master file I uploaded they are not in boolean union thou.


#10

The proper way to design this is to model the pink and yellow solids not separately and try to union, but as a single piece, i.e. a pipe with one round and one flat cap.


#11

Thanks @tomlee! This is what I did (the pipe) for the prongs in center of the model (the blue ones).
And if even if I do boolean union for yellow and pink (or as a pipe) - it won’t always boolean union with the blue stone settings.
Since this is only my second model for wax ever, and the first one with the prongs, it took me a lot of figuring out - how long prongs should be… This is why I made them in 2 separate ways - to change the height easily.
After I will get it printed in wax and then made to a final product - I will see if the prongs are fine and next time will do the in pipe function.

So here what I did at the end -
(I WILL BURN IN HELL FOR PERFECTIONISTS)

  1. I x and y scaled the pink bottom of the prong to 1.01
    .
  2. Then I was able to boolean union yellow and pink parts together. And also boolean union them to the bezels.
  3. Except 2 prongs which was not willing to join the bezel settings. So I added a small cube to add some more “meat” to the prong.

I the link above by @Helvetosaur - (which I will read more in details after I will have a more clue on the topic, otherwise it’s pretty much Chinese) I saw this paragraph. As I understand is the fail to make a boolean union.

"
Known Rhino limitations:

Coincident seams – all objects have
seams, sometimes when the seams on two objects are at exactly the same
place, Rhino will have trouble with the intersection. Solution – either
try to move the seam, or try moving one object just a tiny, tiny bit
(if you can without making your model inaccurate). Or try to do the
operation “manually”.

Coplanar faces – if two faces of an
object are on the same plane, Rhino may not be able to calculate the
intersection. This is a fairly common occurrence, try to avoid building
your model this way if you can. Solution – as above, you may move the
object slightly if possible, if not, you may have to do this operation
“manually”.

Nearly tangent surfaces – like the
intersection of two equal diameter pipes at an angle. The intersection
often fails at the point where the surfaces are tangent. There is no
easy fix currently for this problem.
"

So I believe I sinned on all these 3 points.
But I will burn in perfectionists hell anyway… Sigh…

Thanks everyone for the help!