Bongo 3.0 WIP 7

Bongo 3.0 WIP 7 for Rhino 7 Now Available

Hi all,

** PLEASE NOTE - THIS IS WORK IN PROGRESS SOFTWARE **

USE AT YOUR OWN RISK.

Work-In-Progress versions are not production ready and may hang or crash.

Bongo 2.0 users are encouraged to download and try this WIP release of the animation plug-in for Rhino 7, Bongo 3.0.

Bongo 3.0 WIP 7 is now available from https://www.rhino3d.com/download/bongo/3/wip

Overconstrained

New Features:

  • Physics connections joint velocities
  • Clickable connections in the viewport
  • Added BongoCreatePointAtPivot command

-Full changelog available here

Rhino versions supported: Beta testing Bongo 3.0 is limited to Bongo 2.0 users. Bongo 3.0 requires a Bongo 2.0 license key. Latest version of Rhino 7.0 is required to install Bongo 3.0 and can be downloaded from Rhino - Download - Rhino 7 for Windows

Notes: This is the current work-in-progress release of Bongo 3.0 for Rhino. The product is in the very early stages of development any will probably change a great deal before release. This may include the file format, so please do not rely on Bongo 3.0 models working in the future. Bongo 3.0 will read Bongo 2.0 files, but will save Bongo 3.0 data only. This data cannot be read by Bongo 2.0, so please backup any files before using them in Bongo 3.0.

5 Likes

When I go to settings and increase the number of solver iterations it doesn’t seem to increase the accuracy of the physics. I tried increasing it from 10 to 50, and then to 500. Do I need to go a lot higher to get more accuracy? or is there another way to make sure things don’t fall through other objects?

Hi,
As far as I understand it, the Solver Iterations affect the precision of the connections (if any) in a Physics context. The accuracy of contact (collisions) is improved by increasing the number of ‘Steps per second’.
I usually use 300 for ‘Steps per seconds’ (and 150 for ‘Solver Iterations’). Of course the more steps and/or iterations the longer it takes. I am still considering whether to take these values as default.

When you’ve tried 500 then presumably something else is bugging your model. Can you please post it?

Luc

1 Like