Bone structure&Minimal surface

unhandled

(Smywshdj) #1

hey everyone. I meet a mistake in my grasshopper. When I create the bone structure by using the Minimal surface, I don’t know why I layout some many meshes as result. I think it should layout only one mesh. I checked many times but still don’t know where is wrong. could anyone help me? thank you.

cube.3dm (192.7 KB)
stretched fabric.gh (10.5 KB)


#2

When i “Flatten” the Vertices output on the Explode component, I get this:

// Rolf


(Smywshdj) #3

thank you very much! That is really I want.


(Smywshdj) #4

but when I flatten the vertices, the result mesh is different with the previous meshes…OMG


(Daniel Piker) #5

Here’s your file updated to use the current Kangaroo.
stretchedfabric_k2.gh (13.8 KB)

It runs in a few seconds instead of minutes.
I’d also recommend generating your input mesh a bit differently. Here you start with a lot of triangle ‘fans’ and long skinny triangles, which don’t relax so well.
If you are starting from a Brep, try using the detailed settings when meshing it, and setting a minimum and maximum edge length to get a more uniform edge sizing.