Blocks on layer in worksession can't turn off

I did some searching but didn’t turn anything up and thought i would ask. In a model with blocks you can turn on/off the layers that the blocks are on and in a worksession you can turn on/off sub layers with geometry on them. However, what i find is that in a worksession i can only turn off and on the top level layer for the reference and not any of the lower layers that have block geo on them. In addition, is seems that if a block is nested, then only the lowest level block is shown in the worksession. attached zip with (76.2 KB)

Here is my model structure:
Multiple Rhino files with geo on nested layers -> rhino file with block inserted into context -> worksession with in context model as reference to working file

Hi Nathan - I think what you’re seeing is that you can turn on and off layers that have the block instances, but not the ones that have the definitions, in a worksession, correct? Whereas with a ‘normal’ file, you have access to both…

What is not clear to me yet is whether this is expected/designed behavior, or buggy… I will ask some bigger brains - @mary - do you have an idea?


Hi Pascal,

Ok after some further testing yes, that makes sense and i think that you are right with the issue! if maintain my nested layer structure from the definition model through the instance model can use that to control visibility in the worksession. I think i was getting hung up on the layer trimming that worksessions do with layers that have no geometry on them and losing the layers that needed to control the block visibility.

Thanks for highlighting this!