Blocks are not being sectioned

According to this post this issue seems to have been resolved a few years back, but I having it again.

  1. Clicking Set Plan view to viewport ignores Blocks when doing zoom extent (I have tried to insert them both as linked and embedded and linked blocks). In the image bellow left you can see the result of the command on the plan view.
  2. Blocks are not sectioned even thought the section properties have been assigned. I have tried assigning them both in the original file and to the imported block. In both instances the block is not sectioned on the plan view. Also, in the perspective view the block shows as a two planes and a few lines.

Hi @Filipe_Brandao,

Are blocks inserted as linked? VisualARQ only support normal blocks (not inserted from other files), or inserted as “Link and embed”.

Can you please attach this sample model?



Hello @enric,

Yes. The block was originally inserted as linked and then changed in the properties to embedded and linked. After your reply I tested re-inserting the block as embedded and linked instead of just changing the properties and it solves the issue. Here is the file.

blockIssue.3dm (5.1 MB)