Blendsrf issue V6 vs V5

Experiencing a lot of tangency issues lately. Blend surface between two cut surfaces, as i have done for many years. V5 made it smooth, no issues. V6 has a kink i cannot get rid of. How to address this structurally? As the starting surfaces are part of a large polysurf i cannot/will not change them. Never needed to before. Thanks for any help.

corner issue.3dm (3.9 MB)

Hello - MatchSrf will fix it up (Preserve isocurve direction, Match by closest points) but I see the problem.

In this particular situation,( tangent directions parallel on either side) I might skip BlendSrf altogether and make a loft and then manipulate that with SetSurfaceTangent and MatchSrf for the simplest cleanest result.


It solves the problem but involves a lot of extra work if many of these transitions are to be made, in addition to checking each and every step on continuity. I hope this will be resolved soon?


Still using _BlendSrf, you can get close to V5’s result by using _ShrinkTrimmedSrf followed with _RebuildEdges on the right surface.

Hi Eric - I understand and I agree it should look cleaner - just trying to find you a way out for when things do not work as expected.
The problem I think we’re running into here is that BlendSrf requires ‘Interior shapes’ to be set in this case and with the complex edges here that is intractable (way too many) when it comes to lining up the blend direction. I do not know what the answer is - this behavior is, I believe, what makes other BlendSrf things possible - in particular simple surface structures when the input allows it, (a long time user request) I’ll see if it can be tuned up.


1 Like

Is this the same as mine here?

It took me the longest time to realize that Rhino never cares about edge continuity when it comes to blend surfaces (and matching, I think). You need to manually create matched curves and then fill in your surface, delete the curves and finally match.

So many wasted steps for so many simple surfaces. :frowning:

(Also, if it is the edge alignment issue, it has already been mentioned here and here, and probably in more places too.)

The elephant in the room is that R5 apparently had an answer but we seem to have lost it. The OP’s use case seems to be a pretty commonplace one, so it seems odd to lose that capability for the sake of other, possibly rarer, use cases.


Hello - one of the things we heard a lot was that BlendSrf should make simple surfaces if the input allowed it - as I mentioned above, I believe this is fallout from that change in V6 - you apparently can’t have everything, but the YT item asks to bring it a little closer.


Hi @pascal,

So, if I understand you aright, what you are saying is that because there were use cases that R5 BlendSrf didn’t support, the code was rewritten for R6 in such a way that while it (presumably) supported those use cases it was no longer capable of supporting the OP’s use case.

Given that the OP’s use case is likely to occur frequently, it seems a shame that support for it was dropped. If it can’t be implemented in the R6 code, could the R5 code not be reproduced to give us a BlendSrfR5 with the old functionality alongside the current command?


I hope that the Rhino team will consider to implement the majority of the suggested ideas regarding “Blend surface” in the following topic:


@Steve: if i shrink trimmed surfaces, i loose the ability to revert to the original full size surface when wanting to change later. Huge setback. Shrinking and rebuilding edges are extra actions i never had to do before. So not only extra steps to keep in mind each time, but also a lot of extra time involved.
@Pascal: lofting solves the issue locally, but usually this situation is not on it’s own. See below where the issue is within its surrounding, with all surfaces curved. I now find myself having R5, R6 and R7 open at he same time copy/pasting the best solutions/features among them. As i cannot copy R7 geometry directly into R5, it’s becoming a tedious process.

I do hope there’s a R5 solution in R6/R7 soon.

@ericg sorry to go offtopic here, but man is that a nice viewmode!
would you mind sharing it? would be awesome :wink:

Hi Konrad,
Its standard Rendered mode with some Auxpecker car paint material applied, line colour 50%. Capture to file really big and scale down for nice thin curves.

thanks – yeah I think more than the material it’s those sub 1px curves!
/offtopic off

Hi Eric - this is a bit of an odd ball as far as that goes - rebuilding the edges of this particular surface causes the edges to get quite ugly unless the surface is shrunk first. The trim happens to come very very very close to a fully multiple knot and that is causing trouble…


RH-56944 is fixed in the latest WIP

1 Like

Improved but not entirely fixed.

blend test.3dm (525.9 KB)

I don’t have access to Rhino 7 WIP to see the issue in 3d, so I will explain with text instead. Can you try if the following will help?

  1. Select the surface, use “Rebuild surface” and make it Point count 6 and Degree 5 in either direction.

  2. Right click on the “Match surface” icon (or use “! _MatchSrf _MultipleMatches”) and apply it to all 4 surface edges with the following options: Continuity = Curvature; Distance = 0,001 units (if using millimeters); Tangency = 0,1 degrees; Curvature = 0,05 percent; Isocurve direction adjustment = Preserve isocurve direction (or Match target isocurve direction). Optionally, try “Refine match” and “Match edges by closest points”.

Is it better this way?

It’s not about getting it matched in additional steps, but about the fact that the surface does not match the way it did in V5. If i need to add rebuilding and matching all edges of each and every every blend surface when modelling all day long it requires hundreds of additional actions not needed before. RSI all over again…