Blend failures on the verticese (again)


#1

Blended the edges on this candlestick base and this was the result (0.1 radius). I’m so tired of struggling with all this shit!candlestick base.3dm(698.6 KB) I keep looking round for a replacement for Rhino (that can do this stuff) but the choices are either: fully parametric (yuck!) too expensive, ugly interface or some kind of poly-nurbs mish-mash. It’s like trying to buy a pair of shoes. “I’ll have size nine and a half please”. “We only do them in nine or ten sir”.


#2

Hi,
I found a solution, I hope that it is what you were looking for. Bye!
Sample file:Candlestick base solved 2.3dm(969.8 KB)
Sample image:


#3

Hi Violine
Yeah, the filleting (rounded) works fine: it’s the blending option that doesn’t.


#4

Hi Tone,
I’m not sure I understand what you’re trying to do, what command exactly you want to run for the edges?


#5

If this command is BlendEdge then it also works, try it on the object from step 2.
It is important (for step 1) to choose RailRevolve method because it gives you SplitAtTangens option,
and not forget to MergeAllFaces before BlendEdge.


(Pascal Golay) #6

Hi Tone- you can (often) help these cases with a little rearrangement of the way the surfaces are put together. Violine pointed out one way to get there- starting with the object as is, you can also:

a) Explode the object and DivideAlongCreases SplitAtTangents=Yes. Notice the lower horizontal flats be come separated from the arcs that go up to the next level. Generally filleting will work out better, I find, when tangent (that is curvature discontinuous) surfaces are split into polysurfaces.

b) Rejoin all the parts and then MergeAllFaces. See how all the mitered corners disappear and the flats become single trimmed planes- no diagonal edges at the corners.

This simpler arrangement of the same shape allows the BlendEdge/FilletEdge to clean up better.

Candlestick Base_PG.3dm(478.2 KB)

-Pascal


#7

Lo Viloine
This is partly my error, I forgot to blend all surfaces but if you use the zebra analysis on the vertices you will see that at least one edge in most (if not all) cases is not G2 and is probably G1. I thought things had got worse. My mistake


(Pascal Golay) #8

Hi Tone- you’ll get a better read on even the imperfections with a much finer analysis mesh- try setting ‘Minimum Initial grid quads’ to some thing like 3000-5000 and clear everything else.

-Pascal


#9

Hi Pascal
Thanks for the tip


#10

Thanks Pascal for that tip:)