Blend command produces complex surface


I’m expecting a simple surface structure picking up the single span structure of the adjacent surfaces. The resulting blend does not stay simple, and doesn’t give me the option to do that.

Is this a bug, or am I missing something ?

Please find Rhino file attached.

Thanks,blend issue.3dm (52.4 KB)

Running Version 7 SR11
(7.11.21271.1001, 2021-09-28)

This is, unfortunately, what Rhino does with the BlendSrf command. If you want to preserve the degree and point count, you need to have them be the same across the respective edges. The quickest and easiest way is to bump up the lower degree edge to match the higher degree using ChangeDegree.

Hello - it looks to me like this is happening because one of the surfaces is rational - the upper one in your image. If you set all point weghts to one (Weight command) you should get the expected simple surface.


1 Like

Pascal is, as always, right on this one. You can also Rebuild that top surface to the same point count and degree it was before, and then run BlendSrf you get the surface definition you’re looking for on the blend.

As an aside/follow up - what actions produce rational surfaces? I try to avoid them myself for reasons like this, but when I encounter them I’m not always sure how they came to be rational.

Hi Sky - arcs, circles, ellipses, cylinders, spheres, revolves, tori, are all rational. Surfaces that use rational curves as input - depending on the command - will use the curve input structure in some way in the surface unless told not to - like the Rebuild option in Loft.

Loft, the Sweep commands, EdgeSrf, ExtrudeCrv, RailRevolve will all make rational surfaces from rational input. Revolve will as well, in the around cirection, regardless of the input curve unless the Deformable option is used. networkSrf ignores input structure and makes its own stuff from the 3d shapes - always degree 3 and non-rational.


1 Like


Thanks @sgreenawalt @pascal

Both input srfs hadthe same parameter; degree 2 with 3 cvs. I assumed that the blend would pick up the same parameters; I didn’t consider the weights!

Because I built the surfaces from curves whci were constructed using the arc tools-which I don’t typically do, unless I need true arcs!-the surface weights were not all 1. I normally create a line, then change the degree which by default keeps the weights at 1!

Thanks both.