Black render

I’ve opened an old 3dm file and when I try to render any viewport the render shows up as black.

I tried checking other files and the other files render fine.

So, I saved the file that is having issues as geometry only and this file renders as it ought to. As you all know it, however, I’ve lost ALL the object structure. That’s not going to work.

I’m unsure what’s causing the issue, I turned the sun on / off and tried deleting the infp. I had this same problem before and forgot how I fixed it.

VRAY VFB Console

Preparing renderer...
Preparing scene for rendering...
[RenderView] startCameraTime=0.000000, endCameraTime=2.000000
[RenderView] numCameraTMs=4, numFrames=2, frameSamples=2
Creating a texture cache with size 0 MB
Creating bitmap manager
Bitmap manager created.
1 lights found.
Using probabilistic light evaluation with 16 lights.
Initializing built-in VFB.
[VUtils::DefaultVRayVFB::renderBegin] Progressive sampler cannot be used without a memory frame buffer.
OpenEXR compression type is 3
VFB writing to raw image file
[RenderView] startCameraTime=0.000000, endCameraTime=2.000000
[RenderView] numCameraTMs=4, numFrames=2, frameSamples=2
Max ray intensity is enabled: rendered result may have incorrect brightness.
Cleaning up bitmap manager
Cleaning up texture cache
Maximum memory usage for texman: 0.00 MB
Maximum memory usage for resman: 0.00 MB

Black render defaults to 640 x 480 even though it says it’s 3456 x 2160.

Hi bandaid,

Old files go through a migration process, in order to work with the latest version. Depending on how old the source file is, the migration might not handle the situation correctly, also mind how many configurations and data structures exist in user files.

If it is possible, could you send the .3dm that renders black, to check whether it is a migration or something else. I don’t need textures or any proxy files, just the .3dm.

Thank you

Tried rendering on a different machine with the same version of rhino. On the other machine, rather than rendering black, it renders the objects white with some skewed geometry shadows and flat. When the file fully renders after several minutes it’s displayed as a solid white flat surface.


nope, I do not share these types of files.There ought to be a setting within rhino to clear all caches and other 3d data in a file while keeping the structure intact. The file is only a few months old.

Solved. Something is wonky with ClippingPlanes. Deleted the old clipping plane and added new, however issue occurred again after reopening the file. Deleted and added a new clipping plane.