Black/Blank Viewport in Rhino 7 on Intel Iris 5100 w/Bootcamp

Hi,

I have a user that is working on a Mac with the Intel Iris 5100 GPU in Windows via Bootcamp. When opening Rhino 7, all of the viewports show as black. This issue goes away if they:

  • Set the Display Pipeline assignment to Windows instead of OpenGL
  • Set Rhino.Options.OpenGL.UseHardwareDriver to False

However, it would be nice if OpenGL could be used to its fullest. The issue is not present in Rhino 6 on the same machine. Any advice? Below is the SystemInfo:

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03001, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Commercial, build 2021-04-10
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) Iris™ Graphics 5100 (Intel) Memory: 1GB, Driver date: 11-4-2020 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.5171
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.5171
Driver Date: 11-4-2020
Driver Version: 20.19.15.5171
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

What does SystemInfo look like in V6?

Hi John, thanks for the reply. Here is the SystemInfo for Rhino 6:

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Commercial, build 2020-04-23
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: GUYNO-M-0056

Non-hybrid graphics.
Primary display and OpenGL: Intel(R) Iris™ Graphics 5100 (Intel) Memory: 1GB, Driver date: 11-4-2020 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.5171

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.5171
Driver Date: 11-4-2020
Driver Version: 20.19.15.5171
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I’ll see if I can get a developer to take a look.
Thanks

Eh it’s pretty old–2013?–and was kind of crap in the first place. Rhino 7 makes more use of OpenGL than 6, so…I wouldn’t expect much.

Jim is right.
You’re not going to get any decent OpenGL performance on a computer running an Intel GPU. That just not what they are intended for.

A Mac with an AMD GPU with as much VRAM as you can get will have much better graphics performance.

That said, one of the developers asked to see SystemInfo from V6 and V7 from the same computer like you have. I’ve notified them it’s here.

Thanks

John, Jim,

Thanks, makes sense. I’ll pass on the word about AMD and keep my eye out for any dev replies.

Stay cool,
Joseph

That’s the only thing that stands out to me at the moment… Depending on how his system is configured, Windows may be getting certain signals crossed when loading the display drivers when Rhino starts.

I would be interested in knowing what happens if he makes his laptop monitor the “Main Display”, and the external monitor the secondary display. This is done using Windows->Display Settings dialog.

Or, he can try something even easier… Make sure Rhino is not running, unplug the external monitor and then start Rhino.

If there is no external monitor, then something is confusing V7, which might be some kind of USB display dongle that’s plugged but not used… I just don’t have enough information about the configuration to really know.

-Jeff

Great, thanks Jeff! I will ask the user to play with the Display settings / external monitor to see if anything changes. I will come back and update you when I hear back. :v: