Bison v0.9 Beta: Landscape Plugin for Grasshopper + Rhino 6

Thanks for the quick response

Hi All, a new release was posted last month, so you can still use it!

However, Bison is not yet compatible with Rhino for Mac. This is on the agenda, but not sure when it can be resolved.

Any news on an updated Bison release to keep the (awesome) plugin working in 2020?
Many thanks!

@Bison

Hi Everyone, happy new year! The file has been updated on the site and on food4rhino. There is no expiration date for this one!

2 Likes

@dpmoses

@Bison Happy New Year to you as well- thanks so much for the update!

1 Like

I’ve been using your (wonderful) plugin happily until it expired. But now that I’m trying to install the updated version, I keep getting issues loading the .GHPY file.

Anyone else having issues?

Hi

Thank you for the interesting plugin!
I’m working on a geometry which is a surface with a manual roughness.

I want to compare this geometry with another one with more surface roughness.

When I connect these to the roughness analysis component, the one on the left which is smoother, shows a higher roughness.

How is this possible? Am I making a mistake somewhere?
Below is a screenshot of the right mesh, with apparently lower roughness.

Can I change the range of the tags? So that instead of 0 to 100, I choose a smaller range and it might show the differences in a better way?

I appreciate any help!

Hello! I am excited to try out Bison, but I am having issues downloading it. After adding the file into the components folder, I get this message when re-opening rhino:

ImportException: No module named DataCheck Traceback line…

Any suggestions would be of great help!

I’m having the same issue here, have the latest Rhino 6 update and GH but encountering the same problem. Any ideas? Thanks!

The .ghpy file does not seem to load when placed in the Components folder while running GH 6. No error messages, just the component does not show up in Grasshopper.

Any advice would be great!

Hi - you need to make sure to (1) unblock the file when you download it, and (2) restart Grasshopper and Rhino after having put it in your %appdata%\Grasshopper\Libraries folder.
-wim

Hi,

When importing a DEM, what should we set the X and Y dimensions too? If my DEM file is in Meters, then I assume my rhino file should be in M, logically I would set the X and Y dim to the size of the DEM image in pixels, since on the component it says X/Y in pixels, but when I do that it turns my terrain into a flat sfc. If I set it to 1, it looks OK but maybe too exaggerated…so how do I know what to set it to?

Hi Remy -

The TIFF file will contain meta data that has information about the size and units of each pixel in longitude and latitude. A program such as QGIS will be able to read and display that information.
Note that if the units of the pixel size are in degrees, its size in meters will depend where on earth it is located.
-wim

I brought my DEM into QGIS, exported it as a GeoTIFF. I use that to input into BISON. What should I set my X and Y Dim’s to, in the input mesh component of Bison? If I do not set it, it does nothing. If I set it to 1, it looks too exagerated in height.

Hi -

Perhaps we should start at the beginning. What was the original file format?
Can you post a file?
-wim

It will not let me upload the files here, but they are .dem format, downloaded form this link:

Thanks so much for your help btw!

Hi again, Remy -
I downloaded a part of NY that looked mountainous - F47 - Lake Placid.
I hadn’t encountered .dem files before but that went into QGIS without issues.

QGIS tells me the following:


This DEM is 1015 x 1403 pixels. The units are meters and the size of a pixel is 10,-10 - so, 10 x 10.

Since you need to get this into a different format to get it into Rhino, the easiest is probably to just convert it to an .XYZ file that can be imported straight into Rhino as a point cloud object.
When you get it into Rhino, delete the points around the border of the terrain that are projected to Z=0 by sub-object selecting the points in a side view and just pressing Delete.
With the remaining point cloud selected, run MeshPatch.

That resulted in this:

If you’d rather use Bison and Grasshopper, these settings seem to work:

I set the sampling to 10 to quickly test the result. When that looks correct, you can then decrease to 1 but that will take a lot longer to complete.
-wim

Hi Wim,

Thank you so much for the reply and information - All works perfectly and I understand it now. I did not know about exporting to xyz and being able to import it directly into rhino - oh how this would have saved me over the summer!

Thanks again,
Remy