[Bison] Mesh from GeoTiff has wrong elevation values?

Hi guys,

I have been trying to use the new Bision plug-in to work with GeoTiffs and Meshes.

I downloaded a GeoTiff from OpenTopography and inputted into “Import Mesh DEM” component to generate a mesh from it. But the elevation is clearly exaggerated, I do not understand why… I scaled the mesh in Z just to make it look better, but I would like to have the real elevation as close as possible.

I tend to think it has to do with the plug-in itself, as the GeoTiff is a standard one from OpenTopo…

I also have doubts regarding the dimensions of the mesh, as the inputs seem to be in pixels…
I am not sure what values to input so that the mesh has the real extension in kilometers…
Sample: Sampling factor as nth pixel to read
XDimension: X dimension pixel size.
YDimension: Y dimension pixe size.

Hope someone can shed some light on these issues for me.
Unfortunately Tiff isn’t a supported/authorized extension, so I cant upload it, but if you need more info like the metadata of the GeoTiff I can provide it.

Hi - I’ve tested the GeoTiff import of Bison quite a bit and found it to be very reliable.
You need to find out the real world resolution of the image and use that together with your Rhino document units. For example, the datasets I use are sampled every 0.25 meters and I use all samples. That gives Sample set to 1 and X- and Y-Dimensions set to 0.25 in a Rhino file in meters.

To check the elevation, I selected 1 point where the gumball is and checked that against the map and both are at 179 meters msl.
-wim

Hi wim, thanks for the reply. According to Qgis, this is the metadata of my GeoTiff.

I didn’t quite get how you achieve the ideal values to input in Sample, and X and Y dimensions. Are you able to deduce those from my information or I am missing something?

What do you mean exactly by against the map? All I have is a GeoTiff in grayscale, which I downloaded from OpenTopography by selecting a region.

Edit: (SRTM GL1) Global 30m Ellipsoidal(SRTM_GL1_Ellip) means it sampled every 30meters??

That would mean?
Sample 1:
X and Y dimension = 30
Rhino Units = Meters

Yes - provided you are using all pixels. If not, you can increase the Sample value.

FWIW, I checked what Qgis tells me about the GeoTIFFs I use.
For one of my datasets, Qgis reports this:


… the interesting information being all the way at the bottom:

Pixel Size 0.25, -0.25

and further up:

Unit: meters

But I know that information when I pick the data source from my provider:


(the “(0.25 m)” in Asker 2012 (0.25 m).

Just that I checked against some reference that I know has the exact elevation of a point, in this case a map on the web:


-wim

1 Like

Thank you for the detailed reply Wim! It is nice to compare workflows with someone else.

The units of my GeoTiff are: Degrees. Because it’s CRS is EPSG:4326 - WGS 84 - Geographic. I might need to project it to a CRS that supports SI units.

I am in doubt about pixel size now though. Mine says: 0.00027… , but the data is Global 30m Ellipsoidal.
Maybe I will just use 0.00027 as that is what Qgis says is the pixel size.

Yes, that corresponds with the 30 m or 1 arc-second.
1 arc-second is 0.0002777778 degrees.
So, a pixel is still 30 meters. Have you tried to use that in Bison and see how that comes out in Rhino?
-wim

1 Like

After 12min of calculation it worked! Thank you Wim.

1 Like

Nice!
I see that you down-sampled to 3 - those GeoTIFF files sure lead to some rather large Rhino files… :sunglasses:
-wim

1 Like