Big problems, empty files and crashes

#1

I have a file with problems. I used “save as” to save a copy of the file for rendering (with raytraced viewport mode). I then did “extract render mesh” and deleted the NURBS in the new file, added a ground plane from the library and tried to switch to “raytraced” -> crash. When I re-opened the file it was empty - but not only that - also the original NURBS-file was empty, when I opened it!

I had a copy of the original file on my laptop (and Time Capsule). I made a new ‘save as-copy’, extracted the render mesh and deleted the NURBS-objects in this file. Now the files are ok - except for the fact that the ‘render-file’ always crashes, when I switch to “raytraced”…

I sent the crash report and the file to McNeel (forgot to zip - sorry about that).

Edit: The original NURBS-file doesn’t crash when switching to “raytraced”, so it’s something with the materials I guess.

Philip

Rhino 6 for Mac WIP build 6.15.19086.09026
#2

…and now when I open the ‘render-file’ and press “raytraced” everything is ok - no crashes!
Very strange…

Philip

(Nathan 'jesterKing' Letwory) #3

Did you submit the crash reports with the same email address as your discourse account?

If possible I’d get one of those files that used to crash (even if they don’t anymore)

https://rhino3d.com/upload/?to=nathan@mcneel.com to have it uploaded and addressed to me.

Thanks in advance!

/Nathan

#4

Yes.

I’m afraid it’s not possible anymore… I saved the file as FBX (for rendering in Unreal engine), took a break and closed the file - and when I opened it again it was empty! Just one layer left and no objects at all. I don’t understand…

Philip

#5

Hmmm, actually, if you need it you can get it from @John_Brock. I got a e-mail from John (thanks John!) and he has the file and was able to open it. Do you need the empty file as well?

Philip

(Nathan 'jesterKing' Letwory) #6

@Philip thanks for the info. I’ll dig in our crash report system to see what I can find out. Fingers crossed! edit: unfortunately no entries in the crash report system yet :confused:

@John_Brock, can you forward the file in question to me please, as well? Thank you.

#7

I made a new render file (mesh file), from my NURBS-model. Added materials, groundplane etc. It crashed almost every time I tried to switch to “raytraced.” Sometimes it was crashing when changing material for an object - and finally I couldn’t even open it anymore. It crashes every time I try.

I sent the crash report to McNeel. When I tried to send the file a got a ‘server error.’ I have to try again later…

EDIT: File sent.

Philip

(Nathan 'jesterKing' Letwory) #8

Do you also use linear lights?

#9

Nope. I used only a HDR image (Studio E).

Philip

Save or autosave is deleting nearly everything
#11

I had a new occasion with Rhino emptying a file today. This time it wasn’t related to rendering or materials. I have been working on a new model for some days. As always I export it as a V5 file before I close the (V6) file. When I opened the V6 file after a break it was empty. I’m not able to repeat it (seemed to be completely random). It has (so far) happened only once with this file.
I then opened my backup-V5-file and made that my new V6 file. I’ll send this file to McNeel.

Needless to say that this a bit scary… Latest WIP (6.15.19071.17016).

Philip

(Nathan 'jesterKing' Letwory) #12

When you export to v5 do you also first manually save the v6 document?

How did you close the v6 document? Using the document titlebar icon? Or the File > Close menu? Or the shortcut key? Or just closing Rhino by its menu item? Or its shortcut key?

edit: too early sent, I had more questions:

  • what are the options you export to v5 with? save small? save textures? save geometry only? save plug-in data?
  • do you save the file to some location that gets automatically synced to The Cloud? Or is it an external storage? Or a networked drive?

edit 2: more questions still

  • did you have multiple documents open?
#13

Hi Nathan

No. First exporting as V5 and then closing the V6 file.

Cmd + Q

Save small, save textures, save plugin data.

No, I don’t use (i)Cloud - or any other ‘cloud.’

Nope. Saving to the same folder on the machines hard drive as the V6 file.

No, never. Rhino (still) crashes with multiple documents open when navigating in either file - and both documents are very slow to navigate in. I can only have one document open if I don’t want crashes - and I don’t :wink: I only have two documents open when I want to copy-paste something from some file to the one I’m working in (and I always close the ‘extra’ file immediately after that).

With navigating I mean zooming and/or panning in the file - and then pressing and holding the “home” button (pressing the home button is what causes the sluggishness - and crashes).

Philip

Save or autosave is deleting nearly everything
(Nathan 'jesterKing' Letwory) #14

So no saving of the v6 files if you had made any changes prior to exporting to v5?

#15

A file with changes is always saved in the background whenever you have a pause (for about 20 seconds IIRC) - and when I close the file with Cmd + Q the save dialog always pops up: revert changes, cancel or save. I, of course, always select save, so the file is saved all right.

Philip

(Nathan 'jesterKing' Letwory) #16

Ok thanks, that was the bit of info I was looking for. I’m trying to find the steps that reproduce on my machine he problem you see on yours.

#17

Ok, thanks! :+1: You might have a hard time reproducing it, however - it doesn’t happen very often (thankfully)…

Philip

(Nathan 'jesterKing' Letwory) #18

Well, I’m going to go through the motions regularly, lets hope I run into it sooner rather than later.

1 Like
(Nathan 'jesterKing' Letwory) #19

@Philip, have you run into the case where you find the v6 file you saved opens up as a v5 file according Rhino WIP?

#20

Yes! I forgot to mention that… Good catch! :+1:

Philip

(Nathan 'jesterKing' Letwory) #21

The V6 opens as V5 is reported here: https://mcneel.myjetbrains.com/youtrack/issue/RH-51484

1 Like