Big missing feature - make2d constant scale


#1

Hi,

I need to shot make2d lines from a perspective view of a train. Later I create make2d lines from some selected features only. The problem is that the first set of lines doesn’t match the second set of lines. Please fix it so that the same view create same scaled lines.
Very buggy - also enable “show viewport rectangle” doesn’t help. The rectangle doesn’t match, additional manual alignment is needed.

Regards,
Micha


#2

Just wished this during the working process…


#3

I got caught out by this recently too when using Isometric view.


(Pascal Golay) #4

Hi Micha, All- the not-very-elegant workaround for now is to make an object larger than the ones in your scene and include it in all the shots you take with make2d. In a perspective view, set the cplane to the view and make a large rectangle around the scene. If make2d from this view always includes the rectangle, it can be used to register the sub-make2ds together.

Combine make2d.3dm (92.4 KB)

-Pascal


(Gustavo Fontana) #5

…but shouldn’t “show viewport rectangle” take care of this? Is this a bug, or a common limitation of this approach?

G


(Pascal Golay) #6

Hi Gustavo- my guess is the vp rectangle ends up at different depths in 3d depending on the locations of selected objects. @GregArden, what really happens?

-Pascal


(Gustavo Fontana) #7

it would be cool if viewport rectangle uses your approach of building on the fly (and in the background, hidden from users) a view-cplane. You might recall your script you did for me: the ‘foregrounder’ command in the Backgrounder.rvb script did precisely that to place a pictureframe rectangle on the foreground of a viewport, matching the viewport boundary.Backgrounder.rvb (9.0 KB)


(Greg Arden) #8

This is exactly the problem that the “Show Viewport Rectangle” is supposed to solve. If you are rendering a perspective viewport with this option checked you get a rectangle around your resulting image. If you now go and do another make2d drawing from the same viewport with different objects selected you get a different sized image but if you scale one image to register the two rectangles the images should be perfectly registered.

Some limitations of this are:

  1. Only works in perspective views. Parallel views can be registered by translations ( moving one image to lie on top of the other), no scaling is required. I don’t draw a viewport rectangle since there is no clipping at the viewport boundary in parallel views.
  2. Viewport size is independent of the camera. The aspect ratio of the make2d image is determined by the aspect ratio of the viewport( Width and Height measured in pixels). Unfortunately these number change as toolbars are docked. So if you do the procedure outlined above but change the realestate of docked panels the two rectangles will not register correctly.

Is it item 2 that is causing your problem?

Greg


#9

Parallel view - ok, I can’t enable the rectangle feature, butd if I make2D from different parts of my scene (one is keeped) than the shots doesn’t match (also if the view isn’t changed).

Perspective view - I enabled the rectangle and keep the view constant -> the shots doesn’t match.

Couldn’t placement and scale keeped constant? Is it really impossible to change the code? The current functionality isn’t like expected. Scaling of the make2D results shouldn’t be a regular workflow. At the moment it works like a beta version of the command.


#10

Could you post a file demonstrating that behavior? I never had a problem to match two separate Make2Ds by scaling the viewport rectangles to match as Greg described.


#11

The problem isn’t to scale the 2D drawing, the problem is that it is needed. This kind of workaround shouldn’t be needed. Why not go the simple direct way for the user?


#12

I posted that very question a while back. Some geometry would come out very small while other objects would com out almost in scale. I got the impression that Greg is working on that scale issue for the V6 implementation. Current make2d code seems to be to convoluted to simply fix that.