Beta v6 won't let me save

Hi @pascal

I have a problem where v6 Beta refuses to save.

Recently it’s worked to do a Save As v5, and then again as v6 as a workaround. But now sometimes it won’t let me save at all, or only to v5.

NOTE: An update just popped up on my screen, so I’m installing it. Maybe will fix the prob, but
have any ideas how I can fix this? I’d really hate to have to go back to 5, as I’ve really gotten used to using beta (my own fault!)


Hi Alan - save to some other folder than drop-box and see if that works. Does saving the same file to the drop-box folder work from V5? Repeatedly? We’re looking at the drop-box saving problem and we can’t tell yet if it is specifically a V6 thing.


Ah, ok, I’ll try that next time, as I’ve already closed out to install the update.

I actually work out of Dropbox so would love to have that problem smoothed out. Thanks as always.

Hi @Alan_Farkas,

We’re looking into how we can work with DropBox, Goggle Drive, and other cloud storage services better.

The issue with all of these tools is that they have a background service, running on your system, which is constantly trying to sync file changes to the cloud. Inevitably, you run into a situation where you are trying to save a Rhino file that the service has locked because it is in the process of syncing.

In regards to DropBox, make sure you are using the most up-to-date version of the operating system application. For example, I’m using DropBox for Windows version 40.4.46. Not that this fixes the problem. But it may minimize the occurrence.

– Dale

Thanks, @dale, I’ll do that! And that makes sense, of course.

Hey @dale

Any further thoughts about this not saving? It won’t let me save to anything right now,and I’ve done a bunch of work.

Is this b/c it doesn’t want to save the newest update to the file, or is it because rthe original file I’m working on is in limbo?

Should I just hang out for 15 minutes and see if it can save, or maybe try to sync dropbox?

Hi @Alan_Farkas,

If you pause DropBox sync, can you then save?

– Dale

No, unfortunately not. And since I need to get drawings out I actually just have to continue with the file not being able to save my work. If you have ANY more ideas, I’m all ears.


Hi @Alan_Farkas,

Can you do a SaveAs? Again with DropBox paused…

– Dale

I’ve tried both save and SaveAs, and to multiple places on my computer, both on and off dropbox

So what happens when you try to Save or SaveAs to any location? Are you getting an error?

same as before

Hi @Alan_Farkas,

This is a low level file writing error. So something is up. Can you save to your desktop? I see you’re still saving to DropBox…

– Dale

see edited reply

Well, it quite while printing a PDF, so there’s that. Am I the only one reporting this happening, and is there a Rollback you would suggest I go back to? I’m thinking maybe 2 updates ago?

What PDF printer are you using?

Hi @Alan_Farkas,

I don’t understand. Can you try to explain further? Did you get your file saved?

We have had reports of issues saving to DropBox-synced folder. We can repeat it here, occasionally. But not enough to come to any conclusions.

Don’t believe any of the file saving code has changes in quite a while. But I’ll take a look and see if it’s work trying a prior version.

– Dale

I was printing one of my Layouts to PDF and Rhino crashed, so I did not end up saving

Thank you for looking into prior versions.

NEW: I now have these TMP files which I did not have before - maybe b/c I paused Dropbox Sync, I assume? Any chance these have my work before the crash, and before I could Save the file? If so, how would I go about opening them (computer doesn’t seem to know how to open them)

Hi @Alan_Farkas,

If the .TMP files are really small you can just delete them. Before Rhino begins to save, it saves a tiny file to ensure the folder is writable. Sometimes DropBox prevents us Rhino from deleting this tiny files.

– Dale

@Alan_Farkas, what version of DropBox are you using?