Beta - Chamfer error

When using chamfer with both first and second distance set to 0, I am finding that the command is changing the geometry of input curves.

Fillet does the same thing I think you’re trying to show.
If the curves to be filleted/chamfered are too long or too short, they are shortened or extended so the fillet/chamfer fits.
The radius or distance of Zero makes the command do the curve length adjustment but not create the arc or line segment.

It’s a handy way to “clean up” coplanar, nonparallel curves.

Hi, yes, that’s what I was trying to do but it wasn’t working as expected. Instead of extending the lines to the intersection, it is changing the angle of one of the lines.

My hunch is that the gap between the two was smaller than the tolerance setting and Rhino changed the line rather than extending the two lines to the actual intersection. I don’t know though.

Sorry, that subtlety was completely lost on me.

1 Like

Reading back, I could have been clearer. Sorry. I was rushing to get something out the door and wanted to note this before I forgot.

Hoi Robin, do you have a 3dm file that shows this behavior?

Hi, here it is.

chamfer error.3dm (21.2 KB)