BETA: Can't print to PDF with point clouds on

I’m aware there are issues with PDF printing being discussed, and here is one more.

(6.0.17346.6021, 12/12/2017)

We work with point clouds of scanned buildings, and often display the point cloud in a detail view with dimensions in the layout. But I am unable to print to PDF if there is any point cloud data visible. This is true for either the built-in PDF or the Adobe PDF. (The latter can be chosen if Options/Advanced setting is set to show all printers).

The problem is the time it takes. A half hour later after printing a single sheet the progress bar is still going. Tried Raster, Vector, simple wireframe mode… I finally had to give up. Printing worked fine and quickly if I turned off the point cloud, but that defeats the purpose. Any hints at a resolution or possible fix would be appreciated. Thank you.

Brian Jackson

Hi Brian - thanks for the report - are the point clouds very large? I just printed a 750,000 point cloud and it seems to have worked fine to the built in pdf…


Just checked and the cloud is 1670097 points. Larger than yours but wasn’t an issue before. It’s brought in via a worksession. I often have many more scans turned on when printing but used this one for testing purposes with the PDF issue.

Hi Brian - 1.5 million also OK here - printing from model space, or layout, point cloud attached via worksession… hmmm - does your cloud have point colors? And does the problem go away with a boring cloud that is just object color?


Is this specific to PDF printing or do you see a problem with any printer?
I’m really surprised to hear that raster also fails since that is a completely different path for printing.
I’m assuming you don’t have this problem in V5; is that a correct assumption?


yes it’s odd. I do have color scans but to test I replaced the same scan with color removed (is now uniform color by layer). Same result. But in Vector mode the cloud disappears entirely from the preview window and the PDF document. Color doesn’t seem to be the culprit. So far the only difference as a user I can discern is the built-in Rhino PDF printer shows the point cloud in the Preview window when in Vector mode, whereas the Adobe PDF preview does not.

Would it be possible to send me your model so I can try and reproduce the bug on my computer?

I can. What is the best way to get it to you? It’s quite large. should handle large uploads

I just uploaded a ZIP file of the Layout drawing (tab HP2) and the single point cloud to bring into model space via Worksession. I also cold-booted the computer just to rule that out. Same result. Thank you for looking into this since our office communicates through PDFs.

Thanks, I see that the file came through and will try to take a look at it soon.

I can repeat the bug, thanks! I’ve logged this at
and am working on it now.

RH-43270 is fixed in the latest BETA