Beamview not working, it shows only red beams

I upgraded my karamba version, and then downgraded and this file is not working for me. Can you see something I don’t see? I don’t understand why the beamview is not working.

I attach the necessary files!
of_lapos_pontok.txt (211.6 KB)
of_lapos_vonalak.txt (1.2 MB) (37.1 KB)
Untitled.3dm (7.6 MB)
Sorry for not really specific error, but i got really lost and it worked before!
Thanks in advance!

Hi, can you please clarify in further detail what the problem is? At the moment most of the elements are in compression and therefore show mainly red rendering in the material.

Dear Matthew,
The legend has these rectangular kind of things, not just the colors, I couldn’t find what this means. Secondly the elements are in compression with different values, but the colors are the same red, so it seems the legend is not working as it should.


do you have your MeshEdges in Grasshopper turned on? (Try CTRL+M in Grasshopper to toggle this)

I see different colours in Rhino.

Dear Matthew,
No, I dont’ have the mesh edges turned on, I tried this earlier. But when I turn on the utilization I see the colors too, but I need the axial stress, and in that mode I see this, and these colors are not in the legend.

which version of Karamba3D are you using? I was testing it on


I don’t remember the old version (sorry), then I upgraded to 2.2.0. but it didn’t work so I switched back to 1.3.3. (probably this was the old version). It is still not working.

Can you try upgrading to and see if this works for you. At the moment I cannot help much if I cannot reproduce the error.

I upgraded and it worked for me. Thank you very much for your time and energy.