Battery Prob with WIN10 using Dell XPS15 9560[Solved]


#1

Hi,

Anyone out there using Dell XPS15 9560?
Running WIN10(re-installed WIN for downgrading from Creators Update for text size problems in Rhino64)
WIN is latest as of today 2017/06/12 Win10Pro Ver1607 OS build 14393.1198

Using Rhino64 in Japanese at moment (5 SR13 64-bit
(5.13.60913.21340, 2016/09/13)), and the fan for the graphic card is running even with Rhino runnning in the backgound.
Even more in the foreground even if I’m not doing much, or nothing at all.

DELL XPS15 9560 Laptop has GTX 1050 4GB, and also intel HD graphics 630.
Just running for 20min drained about 10~20% battery…
70% battery remaining but only 2.5 more hours left of battery life.

Anything reported in Rhino software side?
or is this more of WIN10 setting for background apps?

Below is Rhino screenshot.


(Brian James) #2

I haven’t heard of this from other users but I don’t have that specific Dell set up to test either. When you were on Win 10 1703 did you try Rhino 5 service release 14 which addressed display issues in v5 on high DPI monitors after the Windows 1703 update? I wonder if you found the same battery issue with SR 14 and Win 10 1703. Have you also tried running the laptop without Rhino running but using some other graphics intensive app? This could help tell if it is a Rhino specific issue or something else.


#3

Didn’t realize the update was out. Thank you for the info!
Getting it now.
I went for check for Help-> Check for update, but browser sent back
I had the latest service release JFYI.(with the release13)


(Wim Dekeyser) #4

The RH5 SR14 is still only a RC - Release Candidate. If you have Update frequency in the Rhino Options > Updates and Statistics set to Service Release Candidate you should be sent to an update.


#5

Just got the update. =)


#6

Just installed
Version 5 SR14 64-bit
(5.14.522.8390, 2017/05/22)
Set language to Eng Just in case.
Removed the Rhino.exe.manifest file, just in case
and also edited the registry with regedit.

Estimated time of usage ~1hr with 30% battery left.
(well I need to check longer perhaps for better approximation)

Any reccomends for other graphics intensive app? Currently thinking Blender Cycles… not sure if it’s graphics intensive unless during rendering…


(Brian James) #8

Another 3D app would be a good test, maybe even Photoshop too. My main thought was to see if the machine has a battery issue unconnected from Rhino.


#9

I’ll check it out. Thank you again.
The fan on the video card is running to cool the pc,
but I wasn’t expecting much processing to heat up that much just opening rhino and drawing circles and lines.
Maybe some driver issue on PC side.
Need to check a little more.
BTW, is the scaling of the icons also ok in creators update? If it is I might update and see if that changes anything.
For now I’ll just see how it goes over a day or two.


(Brian James) #10

Yes, it should do the same thing the manifest tweak did for you in SR13 but it also addressed some other issues that the creators update caused. You may need to make these changes too for the best display.


#11

@BrianJ

I ran SR14(64bit) with Safe-Mode and the laptop fan isn’t going crazy(I suppose not much heat)
Just Toolbar.rhp is Loaded.

For the SR14(64bit) still fan going crazy just drawing couple of circles.

Is there any difference between the two regarding the video card the software chooses? (Geforce vs. Intel)?

Also, one additional question for the 1607, I put a check on the Override high DPIscaling behavior and the toolbar icons became small again…

(JFYI, I’m using evaluation license at the moment)


(Gustavo Fontana) #12

hi Thoshiaki,

Do you have the version with 4K display ( (3840 x 2160) by any chance? I was going to buy that laptop but I didn’t because a high+performance 4-core i7 + 4k Display + GTX 1050 4GB + thin chassis (small battery) would give only a 2H-2.5H battery life doing 3D work. This is just physics. I don’t think there’s anything wrong with Rhino.

G


#13

Hi @gustojunk
Yes it’s the one with 4K.
Yes I agree that with 3D work I’m not expecting too much battery life but if it’s after drawing doing some work and making the surfaces it’s alright/understandable but, just launching and drawing one line or circle or other simple tasks, I’m not expecting battery to drain…nor have the fan running to need to cool the laptop.
Running some diagnostics on laptop side to check if there’s any issue with the hardware.
Thank you for the comment, and 4K for a laptop this size is not a good choice for portable use…


(Brian James) #14

Yes, Safe Mode runs Rhino without Accelerated Hardware enabled in Options>View>OpenGL. Check what Rhino is using for the GPU on that Options page. I’m wondering if updating the driver for the Nvidia card and/or reducing anti-aliasing sampling in the OpenGL settings within Rhino changes anything.


#15

Hi @BrianJ

Installed photoshop and did some simple effect editing, but laptop is quiet and no fan running, but
just checked some details and seems for photoshop this laptop is running with Intel integrated graphics card. Couldn’t find way to chnage to Geforce yet…

For Rhino it uses Geforce. Is there some setting I need to configure in
Rhino? Attached is setting capture:


#16

@BrianJ

I’ll check dell site and try installing/reinstalling drivers for the video card as well.


(Brian James) #17

Does the OpenGL page say a driver date now?


#18

@BrianJ

The driver for the graphic card is version 21.21.13.7306、A00
on the Dell website released in Jan this year updated in Feb.
There was a new driver released on in May, but that
seems to be for quadro cards. didn’t know XPS15 had quadro models…


(Brian James) #19

Okay, can you provide a screenshot of the OpenGL page again after you installed the driver update? I’m curious if it says a date now instead of NA. I’m not sure if that matters but based on your description of the fan, I’m thinking something about the system is preventing the driver from being used properly to regulate the GPU.


#20

@BrianJ

http://www.dell.com/support/home/jp/ja/jpdhs1/Drivers/DriversDetails?driverId=K5HF9&fileId=3645745120&osCode=WT64A&productCode=xps-15-9560-laptop&languageCode=jp&categoryId=VI

The page for driver download is in Japanese… Maybe due to WIN10 OS being JP ver.
Not sure if I can/should get another driver from ndivia directly…

リリース日means the date of when it was released Jan4.2017,
最終更新日means the date of the latest update which is Feb2.2017

Adding info: Just trying to install the driver again with Clean Install Setting available in the dell nvidia installer. The date says March07,2017. Maybe
this one has some update…


#21

@BrianJ

Thank you for your support. Got a new driver for Nvidia site.
ver 382.53 released on 2017JUN9th
http://www.nvidia.co.jp/download/driverResults.aspx/119974/jp
Couldn’t get it though the GeForce Experience App (couldn’t connect to Nvidia for inside the app)
But just got it directly from Nvidia.
Also dell driver page seems to have older version of the driver only.

Anyway, finally the fan is silent now/off and battery is not draining anymore.
Thank you for your help. Icons are good size and seems ready to go =)

Added “Solved” in the title. Thanks again!