Basic projection of point to surface produces too many points

Hi, I seem to have found a bug with the native “Project” function.
Take the simple example -
Create a sphere.
Place a single point inside the sphere
Select the “Right” viewport
Run the “Project” command
One point is created on the “right” side of the sphere, but two points are created on the “left” side of the sphere.

I’ve recently moved from Rhino 4 to 5 and this seems to be a bug introduced in Rhino 5.



I just tried it in V5 and V6 and it looks right to me.

A point placed inside (or outside) of the sphere is projected normal to the CPlane of the current viewport.
Project makes two more points as expected.

Yea that’s interesting. I tried it on three different surfaces and got the same issue. Did you click on each point just to make sure there is only one at each location?

My Rhino version is 5 SR14 64-bit

Does yours align to that as well John?

BTW, thanks very much for having a look!

Ah, you’re right.

Yea, I’m not going mad!!!

Thanks John.

Thanks for reporting it!


I just tested the fix for this.
It will be included in next week’s WIP.