Bad Surface Trim

Hi guys,

Hope you lot can offer some help, had a little look around the forum but couldnt get anything to work… I’m having some problem with some topography I’m working with; Surface was originally a sketchup import then a surface draped over in Rhino, all good so far but when I go to trim the surface to the original shape it turns bad (photos attached for reference)

Anyone got any idea how I can go about solving this, tried trim and boolean options, same result…

Thank you!!

Hi Toby - try RebuildEdges and see if that does any good.


Cheers Pascal, no good unfortunately :frowning: still the same problem

Is your surface very far from the origin? (topography is often geo-referenced) Somethimes this can cause problems. If the case, try moving it and the trim curve a known distance so they’re close to the world origin, trim, then move back the same distance.


Thats interesting I thought that problem was always confined to parosolid engine type mechanical cad systems. There are published distance limitations for part file and assembly file creation. From memory this is 1Km in opposing directions from part file origin. Go outside this and your part geometry would disappear and weird things would happen. Didn’t think you would see that in Rhino?

Any one more rhino expert than me might be able to provide what Rhinos distance limits are? Keen to know myself for future ref.

OH wait I just remembered I did used to bring my topo’s back to the rhino origin when I used them in my workflow for terrain to mechanical cad…This is probably Toby’s issue as his topo looks massive?

There are no hard distance limitations in Rhino. However when things are very far from the origin and the numbers used start getting huge, the floating point math used to make calculations in all digital computer processes becomes somewhat inaccurate and that could produce errors. (Google this and you’ll find lots of articles on the subject)

The “far from the origin” limitation is a known issue in Rhino, and most often occurs with geo-referenced files (like topography) that are indeed very far from world 0, hence why I suggested trying to move your object.


Cheers for everyone’s help, still no solution so far though. The topo is at the origin point but is very large and I think that might just be the problem, when I trim small rectangles/squares the geometry if fine; but this only works when the trim surface is a closed box (I tried to trim the topo into smaller strips with a series of lines but the same deformation occurs)

Also tried with straight polylines rather than curves, no change. I’ve attached the file if that’s any help, I’m running out of things to try slowly giving up today haha

Bad Topo

Thanks again,

I scaled your model by a factor of .001 so the size went from 2 x 10^7 to 2 x 10^4 and the trim worked but took a while (Top view, apparent intersection on).

Units in your file are set to millimeters. I changed the units to meters and let Rhino rescale.

What davidcockey said…

You have an extents of like 40 x 20 kilometers measured in mm. So the numbers are HUGE. Putting the file in meters, the trim took about 30 seconds here, object is good. The render mesh looked wonky, so I set it to Custom with a max dist edge to srf of 0.1 (meters). It still shows some “blockiness”, but I think that’s because the original topo data was somewhat coarse…