Background grey when shadows turned on


#1

As you can see I have the background set to white here but no matter what I am getting grey (which is a bummer for printing and layouts)


#2

I can’t seem to make grey override happen, maybe you can attach that display mode’s ini. Also, it looks like you have shadows and skylight AO going on at the same time, how are you achieving that?


#3

Sam, just turn on sun and skylight for that effect.


#4

Ah, thanks. And with turning sun on I also get the grey background.


#5

Glad you got yours working and I am glad to hear you are having the same problem… any fix for these McNeel?


(Brian Gillespie) #6

@jeff may have an idea about how to fix this.


(Brian James) #7

Hi ATH,

This is connected to the “use advanced GPU lighting” option. Turn this off in the custom display mode and it should use the white BG.


(Jeff Lasor) #8

I guess I’m missing something here:

  1. Where was it said that “Use Advanced GPU Lighting” was ever turned on? The default for Technical mode is OFF.
  2. Was/is there an attachment here? I’m not seeing it…
  3. Can I get the exported display mode .ini file please… Everything I’ve tried here so far seems to work…yes, I’ve turned the Sun and Skylight ON.

However… When I change the ground plane settings, my background does turn gray (which is odd), but once I update the view, it returns back to white. So something is obviously causing the background color to change in certain situations, and in your case it sounds like it gets stuck that way.

So I’d really like to be working with the exact same display mode settings that you’re using…and possibly a simple scene that you can repeat the problem with (I want to eliminate all possible side-effects caused by me just poking around).

-Jeff


(Jeff Lasor) #9

Just to show you that I’m not FOS :slight_smile:


(Brian James) #10

Hey Jeff, ATH didn’t say what his settings were for advanced GPU but I found that I could recreate the issue described if I customized Technical mode with this option and the lighting described. You obviously don’t get the same thing with the GPU you were using.

No ini file yet… I just repro’d and thought it might be the cause for ATH too.

GTX 690 driver 320.49


(Brian James) #11

I totally knocked off your design…


Here’s the ini file I used too. Copy of Technical.zip(2.1 KB)


(Jeff Lasor) #12

I’d be careful, that’s NDA and copyrighted material…

I think I see what’s going on (in your case anyway)… It’s actually the Skylight setting that’s causing this. When the skylight is ON, Rhino uses the background for “lighting” (called Image Based Lighting (IBL))…by wrapping the entire scene in a sphere and mapping the image to it. However, if/when a solid color is used, it cooks up an image made up entirely of that color…and for some reason, some form of shading is occurring when the sphere is getting drawn.

Try it… change your solid color to Red, and you’ll get a darker shade of red… Gray is just a darker shade of white. It also goes away when you turn off Advanced GPU lighting because that also turns off IBL…but I believe the real problem is somewhere in the skylight code.

Now, whether this is the same thing everyone else is seeing is the question.

Anyone???

-J


#13

yes I see what you mean Jeff. You didn’t say the word, but I would call this a bug for sure. In terms of the IBL for whatever reason I am getting better, more ambient occlusion like, results with a solid color instead of an actual image file so it would be GREAT to have the background setting actually controlling the background despite the Skylight environment.

AND for the sake of thoroughness here is the display . ini.tech-shadows.ini(10.4 KB)


(Jeff Lasor) #14

Yes this is a bug… But…

Why do you have “Use Advanced GPU Lighting” turned ON in a Technical mode? What does it give you that you don’t get if you turn it OFF ?

-J


#15

In my case the only answer is

Which always leads to


#16

HA! :smile: