Background color of panel windows, where are the settings?


where to change the panel background color. Here is a picture of customers panels in gray, what he doesn’t like anymore.



Rhino options > Appearance > Colors > General > Window color 1

Hi Wim,

“Window color 1” changes here the toolbar color, not the panel color.

Perhaps I should be more precise, I am talking about this gray.

Other ideas, perhaps a registry setting?



I may be mistaken here, but the inactive tabs are in Rhino Window color 3; however the active tabs are the Windows native Menu bar color and can’t be changed without changing the system color scheme… Someone correct me if I’m wrong please…


I guess there are two types of active tabs then.

In this picture, the perspective viewport is active — General > Windows color 2
The right, front, top viewports are inactive — General > Windows color 3

I tried tweaking the OS system color scheme to get to the layer tab color but couldn’t find it.
There are several color settings exposed in Rhino 6 in the options > advanced meny but this one isn’t there either.

Yeah, the viewport tab colors are accessible… I think there may have been discussions/requests in the past for some of the other ones that are not. --Mitch

Hey there, I am the customer. :wink:

If I go to _Options / Appearance / Colors and Press [Reset defaults] (German: Standardwerte wiederherstellen), the colors switch back to the original default colors (see 2) until I close the options dialog with either “OK” or “Cancel”. After leaving the options dialog the screen is flickering some microseconds and the ugly dark gray is restored. (see 3).

Rhino 5 SR 12 64-bit 5.12.50810, Win7 Pro 64-bit

Problem solved, thanks to ProcessMonitor (from Sysinternals) and RegEdit. :slight_smile:

I removed the following registry entry that was set to 13160660 = 0xC8D0D4 = 200,208,212 BRG = 212,208,200 RGB = the dark gray in my upper screen shot and everything is back to normal now:

HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Options\UiPaintColors\tab_background

Hi Dirk,

thank you for your engagement and these details.

Have a nice weekend